Hi, > > The main changes in this series are to refactor shared tracing and assertion > > helpers into a common file, unify both pkey selftests on pkey_assert() and > > per-test tracing for consistent diagnostics, and add missing mmap() return > > checks with MAP_FAILED used throughout for readability and consistency. > > Updated, thanks. > > AI review might have found a pre-existing thing: > > https://sashiko.dev/#/patchset/[email protected]
Thanks for the review and the Sashiko link. I will fix the pre-existing issue pointed out by AI review in the next revision. Best regards, Hongfu

