On Wed, Jul 22, 2026 at 06:23:46PM +0300, Ido Schimmel wrote: > > No preference on dst_port / DST_PORT versus other options > > (NHA_FDB_UDP_PORT for example) > I don't see a reason to make the attribute overly specific (to UDP and > FDB), which is why I prefer DST_PORT.
Thanks both. Done in v4: the attribute is now NHA_DST_PORT with a matching "dst_port" keyword in iproute2, and the internal fields follow suit (nh_config.nh_dst_port, nh_info.dst_port). Validation is unchanged -- the port is still accepted only together with NHA_FDB and NHA_GATEWAY -- so the name is generic while the feature stays FDB-only for now, exactly as you suggested. v4: https://lore.kernel.org/netdev/[email protected]/ Thanks, Jack

