Hi Ibrahim,
> Fixes: 57588c71177f ("mac802154: Handle passive scanning")
> Cc: [email protected]
> Signed-off-by: Ibrahim Hashimov <[email protected]>
> Assisted-by: AuditCode-AI:2026.07
> ---
This whole change makes things clearly less and less readable, but I
don't easily see any possible simplification.
Reviewed-by: Miquel Raynal <[email protected]>
If you are willing to fix another possible leak, you can check Sashiko's
feedback agout skb_get() which is likely leaked since down the stack we
clone it and not consume it.
Thanks,
Miquèl