Hi Pratyush and SeongJae! On 5/12/26 6:31 AM, SeongJae Park wrote: > On Mon, 11 May 2026 17:34:09 +0000 [email protected] wrote: > >> From: Pratyush Mallick <[email protected]> >> >> The current selftests/mm/.gitignore hardcodes each generated test binary >> by name, which requires manual updates every time a new test is added. >> >> This series switches to a pattern-matching approach (similar to KVM >> selftests), ignoring everything by default and allowing specific source >> extensions. To accommodate this without tracking generated headers, >> local_config.h is renamed to local_config.h_gen. >> >> Changelog since v2: >> - Split the changes into two separate patches (header rename and >> .gitignore update) >> - Added Suggested-by for David Hildenbrand for the header rename approach. >> - Dropped David's and Yosry's Reviewed-by tags. >> - Kept Lorenzo Stoakes's Reviewed-by and added Mike Rapoport's Acked-by. >> >> Changelog since v1 (RFC): >> - Renamed local_config.h to local_config.h_gen to avoid conflict with !*.h. >> - Updated Makefile, check_config.sh, and affected .c files for the rename. >> - Removed *.mod.c as it was unnecessary. > > Adding previous revision links together [1] would be helpful for people who > willing to see details of previous discussions. > >> >> Pratyush Mallick (2): >> selftests/mm: use pattern matching in .gitignore >> selftests/mm: rename local_config.h to local_config.h_gen > > So, after applying the first patch, we may show local_config.h unexpectedly > shown on 'git status' output? Maybe too trivial thing, but I'm wondering if > we > already considered doing the renaming first.
Just a gentle ping on this patchset, since it has been some time since the last discussion :). Would it make sense to reorder the patches as SeongJae suggested and respin? Pratyush, if you don't have time to send a v4, I would be happy to prepare and send it. Please let me know if you'd like me to. > > [1] https://docs.kernel.org/process/submitting-patches.html#commentary > > > Thanks, > SJ > > [...] > Thanks, Sarthak

