Hi Diogo,
On Mon, 20 Jul 2026 at 17:41, Diogo Silva <[email protected]> wrote:
> The simple KMS helpers are deprecated because they only add an
> intermediate layer between drivers and atomic modesetting.
>
> Open-code drm_simple_encoder_init() by calling drm_encoder_init()
> directly and providing driver-local drm_encoder_funcs.
>
> Signed-off-by: Diogo Silva <[email protected]>
Thanks for your patch!
> --- a/drivers/gpu/drm/renesas/shmobile/shmob_drm_crtc.c
> +++ b/drivers/gpu/drm/renesas/shmobile/shmob_drm_crtc.c
> @@ -29,7 +30,6 @@
> #include <drm/drm_modeset_helper_vtables.h>
> #include <drm/drm_panel.h>
> #include <drm/drm_probe_helper.h>
> -#include <drm/drm_simple_kms_helper.h>
> #include <drm/drm_vblank.h>
>
> #include <video/videomode.h>
> @@ -436,6 +436,10 @@ static const struct drm_encoder_helper_funcs
> encoder_helper_funcs = {
> .mode_fixup = shmob_drm_encoder_mode_fixup,
> };
>
> +static const struct drm_encoder_funcs shmob_encoder_funcs = {
Nit: shmob_drm_encoder_funcs?
> + .destroy = drm_encoder_cleanup,
> +};
> +
> /*
> -----------------------------------------------------------------------------
> * Encoder
> */
Reviewed-by: Geert Uytterhoeven <[email protected]>
Gr{oetje,eeting}s,
Geert
--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email protected]
In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds