On 8/5/26 11:31 PM, Zi Yan wrote:
On Sat Aug 1, 2026 at 2:26 AM EDT, Baolin Wang wrote:
To support checking for various sized mTHPs during mTHP collapse, extend the
check_huge() function prototype to accept two new parameters specifying the
address range and mTHP size, in preparation for the following patches.

No functional changes.

Signed-off-by: Baolin Wang <[email protected]>
---
  .../selftests/mm/folio_split_race_test.c      |  2 +-
  tools/testing/selftests/mm/khugepaged.c       | 66 ++++++++++---------
  tools/testing/selftests/mm/pagemap_ioctl.c    |  2 +-
  .../testing/selftests/mm/prctl_thp_disable.c  |  2 +-
  tools/testing/selftests/mm/soft-dirty.c       |  2 +-
  .../selftests/mm/split_huge_page_test.c       | 14 ++--
  tools/testing/selftests/mm/uffd-common.c      |  4 +-
  tools/testing/selftests/mm/vm_util.c          |  6 +-
  tools/testing/selftests/mm/vm_util.h          |  6 +-
  9 files changed, 56 insertions(+), 48 deletions(-)


<snip>

diff --git a/tools/testing/selftests/mm/vm_util.h 
b/tools/testing/selftests/mm/vm_util.h
index 7799154b67ee..c7ae28dfda63 100644
--- a/tools/testing/selftests/mm/vm_util.h
+++ b/tools/testing/selftests/mm/vm_util.h
@@ -90,9 +90,9 @@ void clear_softdirty(void);
  bool check_for_pattern(FILE *fp, const char *pattern, char *buf, size_t len);
  uint64_t read_pmd_pagesize(void);
  unsigned long rss_anon(void);
-bool check_huge_anon(void *addr, int nr_hpages, uint64_t hpage_size);
-bool check_huge_file(void *addr, int nr_hpages, uint64_t hpage_size);
-bool check_huge_shmem(void *addr, int nr_hpages, uint64_t hpage_size);
+bool check_huge_anon(void *addr, unsigned long size, int nr_hpages, uint64_t 
hpage_size);
+bool check_huge_file(void *addr, unsigned long size, int nr_hpages, uint64_t 
hpage_size);
+bool check_huge_shmem(void *addr, unsigned long size, int nr_hpages, uint64_t 
hpage_size);
  int64_t allocate_transhuge(void *ptr, int pagemap_fd);
  int pageflags_get(unsigned long pfn, int kpageflags_fd, uint64_t *flags);

I get what "size" means only after I see Patch 3 where
gather_after_split_folio_orders() is used. I think len is a better name
if not addr_len and its type should be size_t to match
gather_after_split_folio_orders()'s signature. The rest patches should
have the same rename and type change. Thanks.

Will do.

Otherwise, LGTM.

Acked-by: Zi Yan <[email protected]>

Thanks.

Reply via email to