On Thu, Aug 20, 2026 at 06:04:18PM +0100, Leonardo Bras wrote:
> On Wed, Aug 12, 2026 at 08:12:04PM +0100, Mark Brown wrote:

> > +   // PSTATE.EXLOCK is set to 0 upon any exception to a higher
> > +   // EL, or to GCSCR_ELx.EXLOCKEN for an exception to the same
> > +   // exception level.  See ARM DDI 0487 R_WTXBY.
> > +   new |= compute_exlock(vcpu, mode, target_mode);

> we have here, instead (naming is bad):

>       if (is_exlock_set(vcpu,...))
>               new |= PSR_EXLOCK_BIT;

> this way it looks more like above sets, such as this one a few lines 
> earlier:

>       if (kvm_has_mte(kern_hyp_va(vcpu->kvm)))
>               new |= PSR_TCO_BIT;

> How does that sound?

I have no strong feeelings on that TBH, I can see preferences either
way.

Attachment: signature.asc
Description: PGP signature

Reply via email to