On Wed, 9 Sep 2026 16:12:54 +0200 Manuel Ebner <[email protected]> wrote:
> Mark key words 'gfp' and 'GFP_KERNEL' for syntax-highlighting. > > Suggested-by: SJ Park <[email protected]> > Signed-off-by: Manuel Ebner <[email protected]> > --- > Suggestion: > https://lore.kernel.org/all/[email protected]/ > --- > Documentation/process/deprecated.rst | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/Documentation/process/deprecated.rst > b/Documentation/process/deprecated.rst > index 22a5e62c9..4d4d29b97 100644 > --- a/Documentation/process/deprecated.rst > +++ b/Documentation/process/deprecated.rst > @@ -404,7 +404,7 @@ become, respectively:: > ptr = kmalloc_flex(*ptr, flex_member, count [, gfp] ); > __auto_type ptr = kmalloc_obj(struct foo [, gfp] ); > > -The argument gfp is optional, the default value is GFP_KERNEL. > +The argument `gfp` is optional, the default value is `GFP_KERNEL`. > If `ptr->flex_member` is annotated with __counted_by(), the allocation > will automatically fail if `count` is larger than the maximum > representable value that can be stored in the counter member associated I suggested the change to only 'gfp' and 'GFP_KERNEL' because those are what newly added by your patch. Because this is a separate patch, what about scoping for larger area? I wouldn't request you to update whole inconsistencies in this doc. Making only the paragraph more consistent looks making sense to me. So, how about doing same to "__counted_by()", too, as it is also in the same paragraph? Thanks, SJ [...]

