Hi Petr, Zack - thanks for CCing me! Some comments below:
On 18/09/2026 00:23, Zack Rusin wrote: >> [...] >> Maybe, we should start with something simple, and introduce >> one more panic notifier as a start. It might be called either: >> >> + "panic_hypervisor_list" because "crash_kexec_post_notifiers = true" >> seems to be primary set on hypervisors. >> >> But I would rather make it more generic and call it >> >> + panic_pre_crash_kexec or panic_pre_kdump because there might be >> more notifiers which are either 100% safe and useful or are worth >> the risk before calling crash dump. >> >> We could put there x86/vmware notifiers as a start. And we could later >> move there other important notifiers. >> >> How does that sound, please? > It's a good idea, IMO. We could start with this, Zach commented some implementation details below...and after it gets merged, we could move other hypervisors that currently set "crash_kexec_post_notifiers" to this list and eventually, unexport this symbol. We should avoid having code forcing this parameter, as Petr said, many notifiers are executed if that is set. (I'm CCing Stephen Brennan here, I recall he had problems with this being auto-set, we talked about that in the panic notifiers big discussions in the past heh) The only thing I'd like to suggest: I think we should have a parameter that disables running this list, which would be the opposite of "crash_kexec_post_notifiers". I would implement it as something like: "postpone_pre_kexec_notifiers" or something like that. The parameter would basically "move" this list execution to the same time as the current notifiers, gating them to "crash_kexec_post_notifiers". This way, we'd allow users to debug kexec failures maybe related to the "early" notifiers. WDYT? > [...] > I think that without that default though, x86 oops_end() can enter > crash_kexec(regs) before reaching panic(), for example with > panic_on_oops=1. To cover that path too, I'd call the chain from > __crash_kexec() after the image check and register capture, under the > existing kexec lock. A second call in vpanic(), immediately before > kmsg_dump_desc(), would cover the fallback path. And I think a > set-once guard would prevent duplicate or recursive dispatch. > Regarding this, 2 things: a) I think you could change kexec_should_crash() to "return 0" also in case the new list is set to run, the same is done currently for "crash_kexec_post_notifiers". Makes sense? b) Well, does this whole panic diag thing you're implementing here aims only at x86 guests ? Or would it be possible to run, for example, arm64 guests? Asking this because in x86 and some other architectures (but not arm64[0]), it's possible to override machine_crash_shutdown() handler, and run things prior to a kexec. Take a look on how Hyper-V does that on arch/x86 - this could be just what you need, except if you plan to have it for all architectures heh Finally, if possible please keep me looped in the following patches, I'm very interested on that =) Cheers, Guilherme [0] https://lore.kernel.org/r/[email protected]/

