On Tue, Sep 22, 2026 at 07:58:22PM -0400, Gregory Price wrote: > The MADV_COLD and MADV_PAGEOUT page-walk callback is named after its PTE > implementation even though it is registered as a PMD callback and serves > both LRU operations. > > Rename it to madvise_lru_pmd_entry() before separating the PMD and PTE > paths. > > No functional change intended. > > Assisted-by: LLM > Signed-off-by: Gregory Price (Meta) <[email protected]>
Oh yeah wow I was thinking 'reasonable in that it is the PTE range which the PMD entry spans' but err, no, it does handle THP PMDs too so :) And LRU is a resonable name, it does seem to me that these are the only madvise operations that qualify so all makes sense. So: Reviewed-by: Lorenzo Stoakes (ARM) <[email protected]> > --- > mm/madvise.c | 7 +++---- > 1 file changed, 3 insertions(+), 4 deletions(-) > > diff --git a/mm/madvise.c b/mm/madvise.c > index 00b1be655a8b5..83d54ab385da8 100644 > --- a/mm/madvise.c > +++ b/mm/madvise.c > @@ -361,9 +361,8 @@ static inline int madvise_folio_pte_batch(unsigned long > addr, unsigned long end, > FPB_MERGE_YOUNG_DIRTY); > } > > -static int madvise_cold_or_pageout_pte_range(pmd_t *pmd, > - unsigned long addr, unsigned long end, > - struct mm_walk *walk) > +static int madvise_lru_pmd_entry(pmd_t *pmd, unsigned long addr, > + unsigned long end, struct mm_walk *walk) > { > struct madvise_walk_private *private = walk->private; > struct mmu_gather *tlb = private->tlb; > @@ -581,7 +580,7 @@ static int madvise_cold_or_pageout_pte_range(pmd_t *pmd, > } > > static const struct mm_walk_ops cold_walk_ops = { > - .pmd_entry = madvise_cold_or_pageout_pte_range, > + .pmd_entry = madvise_lru_pmd_entry, > .walk_lock = PGWALK_RDLOCK, > }; > > -- > 2.53.0-Meta > -- Cheers, Lorenzo

