Hi Qiliang On Mon, Sep 28, 2026 at 03:25:34PM +0800, Qiliang Yuan wrote: > +Cc Hyper-V folks and linux-hyperv, since the failure is triggered by > Hyper-V's handling of VMRUN for a nested (L1) hypervisor, i.e. KVM > running on WSL2. > > For the Hyper-V side: the VMRUN is rejected when the guest state has > CR0.PG=0, EFER.LMA=0 and CR3[63:32] != 0, a combination that bare-metal > SVM does not reject. Is that check intentional? If it is not, a > Hyper-V fix would help older KVM versions as well; either way the patch > avoids creating that state in the first place. > > The full patch is here: > https://lore.kernel.org/r/[email protected]
Please share the Windows version from `winver`. My colleague said that it had been fixed. Maybe the change needs to be ported. Thanks, Wei > > Thanks, > Qiliang

