On 10/15/2012 02:18 PM, Gregory CLEMENT wrote:
Add Armada 370/XP specific clocks: core clocks and CPU clocks.

The CPU clocks are only for Armada XP for the SMP mode.

...
+static struct core_clk_fn armada_370_clk_fn = {
+       .get_tclk_freq = armada_370_get_tclk_freq,
+       .get_pck_freq = armada_370_get_pck_freq,
+       .get_fab_freq_opt = armada_370_get_fab_freq_opt,
+};
+
+static struct core_clk_fn armada_xp_clk_fn = {
+       .get_tclk_freq = armada_xp_get_tclk_freq,
+       .get_pck_freq = armada_xp_get_pck_freq,
+       .get_fab_freq_opt = armada_xp_get_fab_freq_opt,
+};
+
+static const __initconst struct of_device_id clk_match[] = {
+       {
+        .compatible = "marvell,armada-370-core-clockctrl",
+        .data =&armada_370_clk_fn,
+        },
+
+       {
+        .compatible = "marvell,armada-xp-core-clockctrl",
+        .data =&armada_xp_clk_fn,
+        },
+       {
+        /* sentinel */
+        }
+};

Gregory,

armada_370_clk_fn and armada_xp_clk_fn cause section mismatches
as they are referenced within __initconst.

You should either rename them to armada_xp_clk_ops or annotate them
with the appropriate attribute.

Sebastian
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to