On 03/17/2013 11:11 AM, Mel Gorman wrote:
On Sun, Mar 17, 2013 at 07:42:39AM -0700, Andi Kleen wrote:
Mel Gorman <mgor...@suse.de> writes:

@@ -495,6 +495,9 @@ typedef enum {
        ZONE_CONGESTED,                 /* zone has many dirty pages backed by
                                         * a congested BDI
                                         */
+       ZONE_DIRTY,                     /* reclaim scanning has recently found
+                                        * many dirty file pages
+                                        */

Needs a better name. ZONE_DIRTY_CONGESTED ?


That might be confusing. The underlying BDI is not necessarily
congested. I accept your point though and will try thinking of a better
name.

ZONE_LOTS_DIRTY ?

+        * currently being written then flag that kswapd should start
+        * writing back pages.
+        */
+       if (global_reclaim(sc) && nr_dirty &&
+                       nr_dirty >= (nr_taken >> (DEF_PRIORITY - sc->priority)))
+               zone_set_flag(zone, ZONE_DIRTY);
+
        trace_mm_vmscan_lru_shrink_inactive(zone->zone_pgdat->node_id,

I suppose you want to trace the dirty case here too.


I guess it wouldn't hurt to have a new tracepoint for when the flag gets
set. A vmstat might be helpful as well.


--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to