On Mon, Apr 01, 2013 at 09:53:18PM +0200, Sam Ravnborg wrote:

SNIP

> > +
> > +MAKE_DEBUG          := DEBUG=1
> > +MAKE_NO_LIBPERL     := NO_LIBPERL=1
> 
> Why all these ugly UPPERCASE names?
> In kbuild files the unwritten rule is that variables
> with global scope are upper-case.
> And variables with local scope are lower case.
> 
> You can find many examples where this is not followed - but this
> is the general approach.

ok, for some reason I'm used to use capitals for makefile
variables ;)


> 
> > +MAKE_MINIMAL        := NO_LIBPERL=1 NO_LIBPYTHON=1 NO_NEWT=1 NO_GTK2=1 
> > NO_DEMANGLE=1 NO_LIBELF=1 NO_LIBUNWIND=1 NO_BACKTRACE=1 NO_LIBNUMA=1 
> > NO_LIBAUDIT=1 NO_LIBBIONIC=1
> 
> Keeping lines less than 120 chars long is good.
> Some people swer to 80 chars.

ok

> 
> > +RUN := \
> > +   MAKE_PURE \
> > +   MAKE_DEBUG \
> > +   MAKE_NO_LIBPERL \
> 
> RUN += MAKE_PURE
> RUN += MAKE_DEBUG
> RUN += MAKE_NO_LIBPERL
> 
> Is so much more readable.
> As a general rule - use \
> to continue lines only when you really have to.

ok

thanks,
jirka
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to