Anand, Brian,

06/12/2013 11:04 PM, Anand Avati пишет:
On 6/11/13 3:59 AM, Maxim Patlasov wrote:

-    if (mode & FALLOC_FL_PUNCH_HOLE) {
+    if (lock_inode)
          mutex_lock(&inode->i_mutex);

+    if (mode & FALLOC_FL_PUNCH_HOLE)
          fuse_set_nowrite(inode);
-    }

Just for clarity, can you make the condition to check FALLOC_FL_PUNCH_HOLE and call to fuse_set_nowrite() nested within the larger if (lock_inode) { .. } block? fuse_set_nowrite() should not be called without i_mutex acquired. The current style of calling mutex_lock() and fuse_set_nowrite() in separate conditions can potentially cause bugs in the future if they were to get re-ordered due to some unrelated patch. Nesting them makes the relation more explicit and clear.

Thanks a lot for review. I'll post updated patch soon.

Thanks,
Maxim

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to