On 23 September 2013 17:40, Jingoo Han <jg1....@samsung.com> wrote:
> Use the wrapper function for retrieving the platform data instead of
> accessing dev->platform_data directly. This is a cosmetic change
> to make the code simpler and enhance the readability.
>
> Signed-off-by: Jingoo Han <jg1....@samsung.com>
> ---
>  drivers/rtc/rtc-88pm860x.c |    2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/rtc/rtc-88pm860x.c b/drivers/rtc/rtc-88pm860x.c
> index 4e30c85..81650484 100644
> --- a/drivers/rtc/rtc-88pm860x.c
> +++ b/drivers/rtc/rtc-88pm860x.c
> @@ -316,7 +316,7 @@ static int pm860x_rtc_probe(struct platform_device *pdev)
>         unsigned long ticks = 0;
>         int ret;
>
> -       pdata = pdev->dev.platform_data;
> +       pdata = dev_get_platdata(&pdev->dev);
>
>         info = devm_kzalloc(&pdev->dev, sizeof(struct pm860x_rtc_info),
>                             GFP_KERNEL);
> --
> 1.7.10.4
>
>

Acked-by: Haojian Zhuang <haojian.zhu...@linaro.org>
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to