On Wed, 2014-08-13 at 00:52 +0300, Kirill A. Shutemov wrote: > On Tue, Aug 12, 2014 at 10:45:23AM -0700, Davidlohr Bueso wrote: > > The most common way of iterating through the list of vmas, is via: > > for (vma = mm->mmap; vma; vma = vma->vm_next) > > > > This patch replaces this logic with a new for_each_vma(vma) helper, > > which 1) encapsulates this logic, and 2) make it easier to read. > > Why does it need to be encapsulated? > Do you have problem with reading plain for()?
No problem in particular. But encapsulation is always good to have, and we have a number of examples similar to what I'm proposing all throughout the kernel (just like at vma_interval_tree_foreach). > Your for_each_vma(vma) assumes "mm" from the scope. This can be confusing > for reader: whether it uses "mm" from the scope or "current->mm". This > will lead to very hard to find bug one day. > I don't like this. > > > It also updates most of the callers, so its a pretty good start. > > > > Similarly, we also have for_each_vma_start(vma, start) when the user > > does not want to start at the beginning of the list. And lastly the > > for_each_vma_start_inc(vma, start, inc) helper in introduced to allow > > users to create higher level special vma abstractions, such as with > > the case of ELF binaries. > > for_each_vma_start_inc() is pretty much the plain for() but with > really_long_and_fancy_name(). Why? Because we can implement things like for_each_vma_gate() on top. Thanks, Davidlohr -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to [email protected] More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/

