This patch removes assignment of variables in if conditions,
as specified in CodingStyle.

Signed-off-by: Bas Peters <baspeter...@gmail.com>
---
 drivers/usb/core/hcd.c | 15 ++++++++++-----
 1 file changed, 10 insertions(+), 5 deletions(-)

diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
index 11cee55..37c40d1 100644
--- a/drivers/usb/core/hcd.c
+++ b/drivers/usb/core/hcd.c
@@ -2683,15 +2683,18 @@ int usb_add_hcd(struct usb_hcd *hcd,
         * bottom up so that hcds can customize the root hubs before hub_wq
         * starts talking to them.  (Note, bus id is assigned early too.)
         */
-       if ((retval = hcd_buffer_create(hcd)) != 0) {
+       retval = hcd_buffer_create(hcd);
+       if (retval != 0) {
                dev_dbg(hcd->self.controller, "pool alloc failed\n");
                goto err_create_buf;
        }
 
-       if ((retval = usb_register_bus(&hcd->self)) < 0)
+       retval = usb_register_bus(&hcd->self);
+       if (retval < 0)
                goto err_register_bus;
 
-       if ((rhdev = usb_alloc_dev(NULL, &hcd->self, 0)) == NULL) {
+       rhdev = usb_alloc_dev(NULL, &hcd->self, 0);
+       if (rhdev == NULL) {
                dev_err(hcd->self.controller, "unable to allocate root hub\n");
                retval = -ENOMEM;
                goto err_allocate_root_hub;
@@ -2733,7 +2736,8 @@ int usb_add_hcd(struct usb_hcd *hcd,
        /* "reset" is misnamed; its role is now one-time init. the controller
         * should already have been reset (and boot firmware kicked off etc).
         */
-       if (hcd->driver->reset && (retval = hcd->driver->reset(hcd)) < 0) {
+       retval = hcd->driver->reset(hcd);
+       if (hcd->driver->reset && retval < 0) {
                dev_err(hcd->self.controller, "can't setup: %d\n", retval);
                goto err_hcd_driver_setup;
        }
@@ -2765,7 +2769,8 @@ int usb_add_hcd(struct usb_hcd *hcd,
        }
 
        /* starting here, usbcore will pay attention to this root hub */
-       if ((retval = register_root_hub(hcd)) != 0)
+       retval = register_root_hub(hcd);
+       if (retval != 0)
                goto err_register_root_hub;
 
        retval = sysfs_create_group(&rhdev->dev.kobj, &usb_bus_attr_group);
-- 
2.1.0

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to