On Sun, Feb 15, 2015 at 5:09 AM, Xunlei Pang <xlp...@126.com> wrote:
> From: Xunlei Pang <pang.xun...@linaro.org>
>
> timekeeping_inject_sleeptime64() is only used by RTC suspend/resume,
> so embrace it in RTC related macros.
>
> Signed-off-by: Xunlei Pang <pang.xun...@linaro.org>
> ---
>  kernel/time/timekeeping.c | 4 ++++
>  1 file changed, 4 insertions(+)
>
> diff --git a/kernel/time/timekeeping.c b/kernel/time/timekeeping.c
> index b124af2..d78a528 100644
> --- a/kernel/time/timekeeping.c
> +++ b/kernel/time/timekeeping.c
> @@ -1125,6 +1125,9 @@ static void __timekeeping_inject_sleeptime(struct 
> timekeeper *tk,
>         tk_debug_account_sleep_time(delta);
>  }
>
> +#if defined(CONFIG_RTC_CLASS) && \
> +       defined(CONFIG_PM_SLEEP) && \
> +       defined(CONFIG_RTC_HCTOSYS_DEVICE)

So RTC_HCTOSYS_DEVICE implies RTC_CLASS, so that could be simplified a bit...

thanks
-john
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to