* Alexei Starovoitov <a...@plumgrid.com> wrote:

> +static const struct bpf_func_proto bpf_trace_printk_proto = {
> +     .func = bpf_trace_printk,
> +     .gpl_only = true,
> +     .ret_type = RET_INTEGER,
> +     .arg1_type = ARG_PTR_TO_STACK,
> +     .arg2_type = ARG_CONST_STACK_SIZE,
> +};

A nit, please align such initializations vertically, for more 
readability:

static const struct bpf_func_proto bpf_trace_printk_proto = {
        .func           = bpf_trace_printk,
        .gpl_only       = true,
        .ret_type       = RET_INTEGER,
        .arg1_type      = ARG_PTR_TO_STACK,
        .arg2_type      = ARG_CONST_STACK_SIZE,
};

(this applies to other patches as well.)

Thanks,

        Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Reply via email to