On 14/10/15 12:42, Mark Rutland wrote:
On Wed, Oct 14, 2015 at 12:20:24PM +0100, Suzuki K. Poulose wrote:
Also renames the symbols to prevent conflicts. e.g,
BLOCK_SHIFT => SWAPPER_BLOCK_SHIFT
This sounds sensible to be, so FWIW:
Acked-by: Mark Rutland <mark.rutl...@arm.com>
I have a couple of minor nits below, though.
diff --git a/arch/arm64/include/asm/kernel-pgtable.h
b/arch/arm64/include/asm/kernel-pgtable.h
new file mode 100644
index 0000000..622929d
--- /dev/null
+++ b/arch/arm64/include/asm/kernel-pgtable.h
@@ -0,0 +1,65 @@
+/*
+ * asm/kernel-pgtable.h : Kernel page table mapping
Drop the filename from the comment. It's redundant and ends up being
painful when refactoring and moving things around.
OK
+
+
+#endif
It would be nice to have the usual comment here for what this is ending,
i.e.
#endif /* __ASM_KERNEL_PGTABLE_H */
Oh yes, will add it.
Thanks
Suzuki
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majord...@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/