linux-kernel
Thread
Date
Earlier messages
Later messages
Messages by Thread
[PATCH] hwmon: pwm-fan: Add const to channels allocation type
Kees Cook
Re: [PATCH] hwmon: pwm-fan: Add const to channels allocation type
Guenter Roeck
[PATCH net-next v3 0/3] net: hash uncached route lists by device
Chris J Arges
[PATCH net-next v3 1/3] ipv4: hash uncached routes by device
Chris J Arges
[PATCH net-next v3 3/3] selftests: net: cover IPv6 uncached route device mismatch
Chris J Arges
[PATCH net-next v3 2/3] ipv6: hash uncached routes by device
Chris J Arges
Re: [PATCH net-next v3 0/3] net: hash uncached route lists by device
Kuniyuki Iwashima
Re: [PATCH net-next v3 0/3] net: hash uncached route lists by device
Chris Arges
Re: [PATCH net-next v3 0/3] net: hash uncached route lists by device
Kuniyuki Iwashima
Re: [PATCH net-next v3 0/3] net: hash uncached route lists by device
Chris Arges
Re: [PATCH net-next v3 0/3] net: hash uncached route lists by device
Kuniyuki Iwashima
[PATCH] iio: imu: st_lsm6dsx: Allocate ext_channels with ARRAY_SIZE()
Kees Cook
Re: [PATCH] iio: imu: st_lsm6dsx: Allocate ext_channels with ARRAY_SIZE()
Lorenzo Bianconi
[PATCH net-next] octeontx2-af: Allocate ikpu2 with ARRAY_SIZE()
Kees Cook
Re: [PATCH net-next] octeontx2-af: Allocate ikpu2 with ARRAY_SIZE()
Ratheesh Kannoth
Re: [PATCH] slimbus: qcom-ngd-ctrl: match downstream DEF_ACT_CHAN encoding
Srinivas Kandagatla
[PATCH net-next v6 0/3] net/sched: sch_fq_pie: add per-flow class statistics
Hemendra M. Naik
[PATCH net-next v6 2/3] selftests: tc-testing: add fq_pie per-flow class stats test
Hemendra M. Naik
[PATCH net-next v6 1/3] net/sched: sch_fq_pie: add per-flow statistics via class ops
Hemendra M. Naik
[PATCH net-next v6 3/3] net/sched: pie: correct tc_pie_xstats field documentation
Hemendra M. Naik
Re: [PATCH net-next v6 0/3] net/sched: sch_fq_pie: add per-flow class statistics
Jakub Kicinski
Re: [PATCH net-next v6 0/3] net/sched: sch_fq_pie: add per-flow class statistics
Hemendra M. Naik
[PATCH] scsi: hpsa: Make buff allocation type unsigned
Kees Cook
[PATCH] regulator: axp20x: Remove const from new_desc allocation types
Kees Cook
Re: [PATCH] regulator: axp20x: Remove const from new_desc allocation types
Mark Brown
[PATCH] power: supply: qcom_smbx: Remove const from desc allocation type
Kees Cook
Re: [PATCH] power: supply: qcom_smbx: Remove const from desc allocation type
Konrad Dybcio
[PATCH] pinctrl: s32cc: Remove const from groups allocation type
Kees Cook
[PATCH] gpio: it87: Remove const from labels_table allocation type
Kees Cook
[PATCH] hwmon: scmi: Fix info[] allocation type
Kees Cook
Re: [PATCH] hwmon: scmi: Fix info[] allocation type
Guenter Roeck
Re: [PATCH] hwmon: scmi: Fix info[] allocation type
Guenter Roeck
[PATCH] 9p: Add const and unsigned to wnames allocation type
Kees Cook
Re: [PATCH] 9p: Add const and unsigned to wnames allocation type
Dominique Martinet
[PATCH] iio: adc: ad7173: Remove const from chan_arr allocation type
Kees Cook
Re: [PATCH] iio: adc: ad7173: Remove const from chan_arr allocation type
Andy Shevchenko
Re: [PATCH] iio: adc: ad7173: Remove const from chan_arr allocation type
Joshua Crofts
[PATCH] ASoC: codecs: wm8958: Add const to enum texts allocation types
Kees Cook
Re: [PATCH] ASoC: codecs: wm8958: Add const to enum texts allocation types
Charles Keepax
Re: [PATCH] ASoC: codecs: wm8958: Add const to enum texts allocation types
Cezary Rojewski
Re: [PATCH] ASoC: codecs: wm8958: Add const to enum texts allocation types
Mark Brown
[PATCH] ASoC: SOF: topology: Add const to tplg_files allocation type
Kees Cook
Re: [PATCH] ASoC: SOF: topology: Add const to tplg_files allocation type
Mark Brown
[PATCH v3] drivers/hv: remove deposited pages from direct map
Magnus Kulke
Re: [PATCH v3] drivers/hv: remove deposited pages from direct map
Mukesh R
Re: [PATCH v3] drivers/hv: remove deposited pages from direct map
Magnus Kulke
[PATCH] coresight: cti: Add const to con_groups allocation type
Kees Cook
[PATCH] hwmon: hp-wmi-sensors: Fix info_map[] allocation type
Kees Cook
Re: [PATCH] hwmon: hp-wmi-sensors: Fix info_map[] allocation type
James Seo
Re: [PATCH] hwmon: hp-wmi-sensors: Fix info_map[] allocation type
Guenter Roeck
[PATCH] memory: emif: Remove const from min_tck allocation type
Kees Cook
[PATCH] modules/kmod: Allocate argv with kmalloc_array()
Kees Cook
[PATCH] KVM: selftests: Drop the unsigned >= 0 assertions in test_write/test_read
Gokul K
Re: [PATCH] KVM: selftests: Drop the unsigned >= 0 assertions in test_write/test_read
Sean Christopherson
Re: [PATCH v2 0/6] cpuidle: speed up do_idle() by caching the governor latency QoS constraint
Rafael J. Wysocki (Intel)
Re: [PATCH v2 0/6] cpuidle: speed up do_idle() by caching the governor latency QoS constraint
Yaxiong Tian
Re: [PATCH v2 0/6] cpuidle: speed up do_idle() by caching the governor latency QoS constraint
Rafael J. Wysocki (Intel)
[PATCH v9 0/4] media: add virtio-media driver
Brian Daniels
[PATCH v9 3/4] media: virtio: Add scatterlist builder
Brian Daniels
[PATCH v9 2/4] media: virtio: Add session management
Brian Daniels
Re: [PATCH v9 2/4] media: virtio: Add session management
Albert Esteve
[PATCH v9 1/4] media: virtio: Add skeleton virtio-media driver
Brian Daniels
Re: [PATCH v9 1/4] media: virtio: Add skeleton virtio-media driver
Albert Esteve
[PATCH v9 4/4] media: virtio: Add ioctl operations and driver logic
Brian Daniels
Re: [PATCH v9 4/4] media: virtio: Add ioctl operations and driver logic
Albert Esteve
[PATCH v4 0/4] remoteproc: imx_rpoc: use memory-region-names to avoid hidden ABI.
Frank . Li
[PATCH v4 4/4] arm64: dts: freescale: add DT overlay for MX95-15x15-FRDM RPMSG usage
Frank . Li
[PATCH v4 1/4] dt-bindings: remoteproc: imx_rproc: document memory-region-names to avoid hidden ABI
Frank . Li
[PATCH v4 2/4] remoteproc: imx_rpoc: use memory-region-names to avoid hidden ABI
Frank . Li
[PATCH v4 3/4] arm64: dts: freescale: imx95-15x15-frdm: remove some rmem regions
Frank . Li
[PATCH 00/10] mm/damon: improve readability, clarity and test coverage
SJ Park
[PATCH 09/10] selftests/damon/sysfs_memcg_path_leak: fail only for real DAMON leak
SJ Park
Re: [PATCH 00/10] mm/damon: improve readability, clarity and test coverage
SJ Park
[PATCH 07/10] mm/damon/tests/core-kunit: test eligible_mem_bp commitment
SJ Park
[PATCH 08/10] mm/damon/tests/core-kunit: add probe_hits_wsum damos filter commit test
SJ Park
Re: [PATCH 00/10] mm/damon: improve readability, clarity and test coverage
Andrew Morton
[PATCH v3 00/20] kbuild: significantly speed up kernel builds
Lorenzo Stoakes (ARM)
[PATCH v3 07/20] kallsyms: reimplement mksysmap in C
Lorenzo Stoakes (ARM)
Re: [PATCH v3 07/20] kallsyms: reimplement mksysmap in C
Kees Cook
[PATCH v3 17/20] objtool: decode instructions and resolve branch targets in parallel
Lorenzo Stoakes (ARM)
[PATCH v3 14/20] kbuild: batch module finalisation
Lorenzo Stoakes (ARM)
Re: [PATCH v3 14/20] kbuild: batch module finalisation
Kees Cook
[PATCH v3 13/20] modpost: emit module descriptors as assembly
Lorenzo Stoakes (ARM)
[PATCH v3 20/20] kbuild: compress the kernel with pigz if available
Lorenzo Stoakes (ARM)
Re: [PATCH v3 20/20] kbuild: compress the kernel with pigz if available
Kees Cook
Re: [PATCH v3 20/20] kbuild: compress the kernel with pigz if available
Manuel Ebner
[PATCH v3 18/20] rust: make exports.o depend on the headers generated for it
Lorenzo Stoakes (ARM)
[PATCH v3 11/20] kbuild: avoid re-running compiler and linker probes
Lorenzo Stoakes (ARM)
Re: [PATCH v3 11/20] kbuild: avoid re-running compiler and linker probes
Kees Cook
Re: [PATCH v3 11/20] kbuild: avoid re-running compiler and linker probes
Nathan Chancellor
Re: [PATCH v3 11/20] kbuild: avoid re-running compiler and linker probes
Kees Cook
Re: [PATCH v3 11/20] kbuild: avoid re-running compiler and linker probes
Nathan Chancellor
[PATCH v3 04/20] kbuild: do not sort nm output where the order is irrelevant
Lorenzo Stoakes (ARM)
Re: [PATCH v3 04/20] kbuild: do not sort nm output where the order is irrelevant
Kees Cook
Re: [PATCH v3 04/20] kbuild: do not sort nm output where the order is irrelevant
Nicolas Schier
[PATCH v3 08/20] kbuild: cache list, composite object state per object
Lorenzo Stoakes (ARM)
Re: [PATCH v3 08/20] kbuild: cache list, composite object state per object
Kees Cook
Re: [PATCH v3 08/20] kbuild: cache list, composite object state per object
Nicolas Schier
[PATCH v3 05/20] kbuild: only emit vmlinux relocations when required
Lorenzo Stoakes (ARM)
Re: [PATCH v3 05/20] kbuild: only emit vmlinux relocations when required
Kees Cook
Re: [PATCH v3 05/20] kbuild: only emit vmlinux relocations when required
Lorenzo Stoakes (ARM)
Re: [PATCH v3 05/20] kbuild: only emit vmlinux relocations when required
Nicolas Schier
[PATCH v3 06/20] elf-parse: add section flags, symbol binding and a read-only mapping
Lorenzo Stoakes (ARM)
Re: [PATCH v3 06/20] elf-parse: add section flags, symbol binding and a read-only mapping
Kees Cook
[PATCH v3 16/20] objtool: size the instruction hash to the text
Lorenzo Stoakes (ARM)
[PATCH v3 01/20] kbuild: do not allocate .modinfo in vmlinux
Lorenzo Stoakes (ARM)
Re: [PATCH v3 01/20] kbuild: do not allocate .modinfo in vmlinux
Kees Cook
Re: [PATCH v3 01/20] kbuild: do not allocate .modinfo in vmlinux
Lorenzo Stoakes (ARM)
Re: [PATCH v3 01/20] kbuild: do not allocate .modinfo in vmlinux
Nathan Chancellor
Re: [PATCH v3 01/20] kbuild: do not allocate .modinfo in vmlinux
Nicolas Schier
Re: [PATCH v3 01/20] kbuild: do not allocate .modinfo in vmlinux
Nathan Chancellor
Re: [PATCH v3 01/20] kbuild: do not allocate .modinfo in vmlinux
Kees Cook
Re: [PATCH v3 01/20] kbuild: do not allocate .modinfo in vmlinux
Lorenzo Stoakes (ARM)
[PATCH v3 19/20] kbuild: build rust crates in parallel with the rest of the build
Lorenzo Stoakes (ARM)
[PATCH v3 10/20] kbuild: move the toolchain checks into init/Kconfig.toolchain
Lorenzo Stoakes (ARM)
Re: [PATCH v3 10/20] kbuild: move the toolchain checks into init/Kconfig.toolchain
Kees Cook
Re: [PATCH v3 10/20] kbuild: move the toolchain checks into init/Kconfig.toolchain
Nathan Chancellor
Re: [PATCH v3 10/20] kbuild: move the toolchain checks into init/Kconfig.toolchain
Lorenzo Stoakes (ARM)
Re: [PATCH v3 10/20] kbuild: move the toolchain checks into init/Kconfig.toolchain
Nicolas Schier
Re: [PATCH v3 10/20] kbuild: move the toolchain checks into init/Kconfig.toolchain
Nathan Chancellor
Re: [PATCH v3 00/20] kbuild: significantly speed up kernel builds
Linus Torvalds
Re: [PATCH v3 00/20] kbuild: significantly speed up kernel builds
Lorenzo Stoakes (ARM)
Re: [PATCH v3 00/20] kbuild: significantly speed up kernel builds
Lorenzo Stoakes (ARM)
Re: [PATCH v3 00/20] kbuild: significantly speed up kernel builds
Nick Desaulniers
[PATCH v3 09/20] kbuild: implement and use depcheck to check dependency timestamps
Lorenzo Stoakes (ARM)
Re: [PATCH v3 09/20] kbuild: implement and use depcheck to check dependency timestamps
Kees Cook
Re: [PATCH v3 09/20] kbuild: implement and use depcheck to check dependency timestamps
Kees Cook
[PATCH v3 15/20] objtool: cache relocations, do less work, eliminate relocation hash
Lorenzo Stoakes (ARM)
[PATCH v3 03/20] kallsyms: output binary data to speed output and kallsyms assembly
Lorenzo Stoakes (ARM)
Re: [PATCH v3 03/20] kallsyms: output binary data to speed output and kallsyms assembly
Kees Cook
[PATCH v3 02/20] kallsyms: index symbols by token to speed up table compression
Lorenzo Stoakes (ARM)
Re: [PATCH v3 02/20] kallsyms: index symbols by token to speed up table compression
Kees Cook
Re: [PATCH v3 02/20] kallsyms: index symbols by token to speed up table compression
Lorenzo Stoakes (ARM)
[PATCH v3 12/20] modpost: cache section relocation mismatch state
Lorenzo Stoakes (ARM)
Re: [PATCH] selftests: livepatch: do not require a kernel build tree to run
Petr Mladek
[PATCH] rpmsg: qcom_smd: Fix edge of_node leak in qcom_smd_edge_release()
Wentao Liang
[PATCH v9 0/4] kallsyms: embed source file:line info in kernel stack traces
Sasha Levin
[PATCH v9 2/4] kallsyms: extend lineinfo to loadable modules
Sasha Levin
[PATCH v9 3/4] kallsyms: delta-compress lineinfo tables for ~2.7x size reduction
Sasha Levin
[PATCH v9 1/4] kallsyms: embed source file:line info in kernel stack traces
Sasha Levin
[PATCH v9 4/4] kallsyms: add KUnit tests for lineinfo feature
Sasha Levin
[PATCH 0/3] kmemleak: fix stale documentation and raise the verbose default
Breno Leitao
[PATCH 1/3] Documentation: kmemleak: describe the metadata pool, not the early log
Breno Leitao
Re: [PATCH 1/3] Documentation: kmemleak: describe the metadata pool, not the early log
Catalin Marinas
[PATCH 3/3] mm: kmemleak: raise min_unref_scans to 3 for verbose auto-scan
Breno Leitao
Re: [PATCH 3/3] mm: kmemleak: raise min_unref_scans to 3 for verbose auto-scan
Andrew Morton
Re: [PATCH 3/3] mm: kmemleak: raise min_unref_scans to 3 for verbose auto-scan
Catalin Marinas
Re: [PATCH 3/3] mm: kmemleak: raise min_unref_scans to 3 for verbose auto-scan
Breno Leitao
Re: [PATCH 3/3] mm: kmemleak: raise min_unref_scans to 3 for verbose auto-scan
Catalin Marinas
[PATCH 2/3] Documentation: kmemleak: fix stale statements about scanning
Breno Leitao
Re: [PATCH 2/3] Documentation: kmemleak: fix stale statements about scanning
Catalin Marinas
[PATCH v1 1/1] tpm: tis_i2c: Deassert optional reset line before probing
Stefano Radaelli
Re: [PATCH v1 1/1] tpm: tis_i2c: Deassert optional reset line before probing
Jarkko Sakkinen
[PATCH] nvdimm/bus: Fix dev double put in nd_async_device_register()
Wentao Liang
Re: [PATCH bpf-next v2 1/3] bpftool: Skip non-autoload programs when generating light skeletons
Quentin Monnet
Re: [PATCH bpf-next v2 2/3] bpftool: Compute light skeleton ctx.sz without relying on links
Quentin Monnet
[PATCH] ieee802154: atusb: Fix URB reference leak in atusb_work_urbs()
Wentao Liang
Re: [PATCH] ieee802154: atusb: Fix URB reference leak in atusb_work_urbs()
Miquel Raynal
[PATCH v2] dm-delay: advertise flush support when a flush delay is configured
Matthias Goergens
Re: [PATCH v2] dm-delay: advertise flush support when a flush delay is configured
Mikulas Patocka
[PATCH 0/9] selftests/mm: improve mremap_test
Sarthak Sharma
[PATCH 3/9] selftests/mm: mremap_test: fail unexpected mremap successes
Sarthak Sharma
[PATCH 4/9] selftests/mm: mremap_test: correct multiple VMA range size
Sarthak Sharma
[PATCH 6/9] selftests/mm: mremap_test: replace random data with deterministic pattern
Sarthak Sharma
[PATCH 7/9] selftests/mm: mremap_test: remove perf tests and timing
Sarthak Sharma
[PATCH 1/9] selftests/mm: mremap_test: use kselftest helpers
Sarthak Sharma
[PATCH 9/9] selftests/mm: mremap_test: strengthen multi VMA validation
Sarthak Sharma
[PATCH 2/9] selftests/mm: mremap_test: skip test when userfaultfd is unavailable
Sarthak Sharma
[PATCH 5/9] selftests/mm: mremap_test: fail on data corruption
Sarthak Sharma
[PATCH 8/9] selftests/mm: mremap_test: remove validation threshold
Sarthak Sharma
[PATCH net v3] selftests/net: run tun tests in a dedicated network namespace
Edoardo Canepa
[PATCH v6 0/4] virtio-gpu: Add userptr support for compute workloads
Honglei Huang
[PATCH v6 2/4] drm/virtgpu api: add blob userptr resource
Honglei Huang
[PATCH v6 4/4] drm/virtio: wire blob ioctl creation to userptr objects
Honglei Huang
[PATCH v6 1/4] drm/virtio-gpu: Add VIRTIO_GPU_CAPSET_ROCM capability
Honglei Huang
[PATCH v6 3/4] drm/virtio: implement userptr support for zero-copy memory access
Honglei Huang
[PATCH 1/2] selftests/filesystems/openat2: fix O_LARGEFILE definitions for non-arm64 architectures
Disha Goel
[PATCH 2/2] selftests/filesystems/openat2: make /tmp a mountpoint inside private namespace
Disha Goel
[PATCH v8 0/3] hwspinlock: convert to XArray and add debug capabilities
Wolfram Sang
[PATCH v8 1/3] hwspinlock: Convert to XArray
Wolfram Sang
[PATCH v8 3/3] hwspinlock: add low level debug capabilities
Wolfram Sang
[PATCH v8 2/3] hwspinlock: add list of locks to debugfs
Wolfram Sang
[PATCH v10 0/2] Add initial dual front camera and rear flash support for Pixel 3 / 3 XL
David Heidelberg via B4 Relay
[PATCH v10 2/2] arm64: dts: qcom: sdm845-google: Enable PMI8998 camera flash LEDs
David Heidelberg via B4 Relay
[PATCH v10 1/2] arm64: dts: qcom: sdm845-google: Add dual front IMX355 cameras
David Heidelberg via B4 Relay
Re: [PATCH v10 1/2] arm64: dts: qcom: sdm845-google: Add dual front IMX355 cameras
Konrad Dybcio
RE: [PATCH v3 21/22] reset: starfive: Add StarFive JHB100 reset driver
Hal Feng
Re: [PATCH v3 21/22] reset: starfive: Add StarFive JHB100 reset driver
Changhuang Liang
[PATCH] dm-pcache: Fix use-after-free in kset_replay()
Wentao Liang
[PATCH] rpmsg: glink: Implement get_mtu callback
Chunkai Deng
Re: [PATCH v14 19/22] KVM: selftests: Finalize TD memory as part of kvm_arch_vm_finalize_vcpus
Peter Fang
Re: [PATCH v1 4/4] x86/vmware: Run panic diagnostics before kdump by default
Petr Mladek
Re: [PATCH v1 4/4] x86/vmware: Run panic diagnostics before kdump by default
Zack Rusin
Re: [PATCH v1 4/4] x86/vmware: Run panic diagnostics before kdump by default
Guilherme G. Piccoli
Re: [PATCH v1 4/4] x86/vmware: Run panic diagnostics before kdump by default
Zack Rusin
Re: [PATCH v14 11/22] KVM: selftests: Set up TDX boot parameters region
Peter Fang
[PATCH] rust: macros: allow non-ASCII characters in `authors`
ThiƩbaud Weksteen
Re: [PATCH] rust: macros: allow non-ASCII characters in `authors`
Gary Guo
[PATCH v2 0/3] ESWIN EPH8621 touchscreen support for Fairphone (Gen. 6)
Luca Weiss
[PATCH v2 2/3] Input: Add driver for ESWIN EPH8621 touchscreen IC
Luca Weiss
Earlier messages
Later messages