Jakub Kicinski <[email protected]> writes:

> On Fri, 9 Aug 2024 14:36:17 +0200 Petr Machata wrote:
>> > +    env_level = env.get('VERBOSE')
>> > +    set_verbosity(env_level)
>> > +  
>> 
>> Actually, the ksft_setup() here was merged last week, and I think that
>> would be a better place to put this stuff. It already handles
>> DISRUPTIVE, it should IMHO handle VERBOSE as well.
>
> I was wondering about that too, FWIW, but the counter argument is that
> VERBOSE has little to do with ksft. It doesn't even include the #
> prefix on the list it outputs by itself (unlike ksft_pr() which does).
>
> Maybe we do as you suggest but rename verbose() to ksft_dbg() and
> make it act more like ksft_pr()?

That would make sense to me.

Reply via email to