On 8/31/2026 8:25 AM, Ackerley Tng via B4 Relay wrote: > From: Ackerley Tng <[email protected]> > > Rename kvm_mem_is_private() to kvm_is_private_gfn() to prepare for in-place > conversion, where there will be two lookup functions, > kvm_vm_is_private_gfn() and kvm_gmem_is_private_gfn(). > > This renaming allows consistent prefixing of "vm" vs "gmem" for > kvm_*_is_private_gfn(), as opposed to kvm_gmem_mem_is_private(), which > looks like a typo. > > Suggested-by: Sean Christopherson <[email protected]> > Signed-off-by: Ackerley Tng <[email protected]> Reviewed-by: Binbin Wu <[email protected]>
- [PATCH v12 00/45] guest_memfd: In-place conversi... Ackerley Tng via B4 Relay
- [PATCH v12 03/45] KVM: guest_memfd: Introdu... Ackerley Tng via B4 Relay
- [PATCH v12 02/45] KVM: guest_memfd: Use kvm... Ackerley Tng via B4 Relay
- Re: [PATCH v12 02/45] KVM: guest_memfd:... David Hildenbrand (Arm)
- [PATCH v12 07/45] KVM: Rename kvm_mem_is_pr... Ackerley Tng via B4 Relay
- Re: [PATCH v12 07/45] KVM: Rename kvm_m... Fuad Tabba
- Re: [PATCH v12 07/45] KVM: Rename kvm_m... Binbin Wu
- [PATCH v12 04/45] KVM: Rename KVM_GENERIC_M... Ackerley Tng via B4 Relay
- [PATCH v12 10/45] KVM: Consolidate private ... Ackerley Tng via B4 Relay
- [PATCH v12 05/45] KVM: Enumerate support fo... Ackerley Tng via B4 Relay
- [PATCH v12 06/45] KVM: Rename memory attrib... Ackerley Tng via B4 Relay
- [PATCH v12 20/45] KVM: SEV: Make 'uaddr' pa... Ackerley Tng via B4 Relay
- [PATCH v12 08/45] KVM: Provide generic inte... Ackerley Tng via B4 Relay
- [PATCH v12 09/45] KVM: guest_memfd: Stub in... Ackerley Tng via B4 Relay
- Re: [PATCH v12 09/45] KVM: guest_memfd:... Fuad Tabba
- Re: [PATCH v12 09/45] KVM: guest_memfd:... Binbin Wu
- Re: [PATCH v12 09/45] KVM: guest_memfd:... David Hildenbrand (Arm)
