On Tue, Jul 07, 2009 at 07:52:57AM -0400, Chaithrika U S wrote:
> diff --git a/arch/arm/mach-davinci/include/mach/dm646x.h 
> b/arch/arm/mach-davinci/include/mach/dm646x.h
> index 0585484..1f247fb 100644
> --- a/arch/arm/mach-davinci/include/mach/dm646x.h
> +++ b/arch/arm/mach-davinci/include/mach/dm646x.h
> @@ -26,4 +26,28 @@ void __init dm646x_init(void);
>  void __init dm646x_init_mcasp0(struct snd_platform_data *pdata);
>  void __init dm646x_init_mcasp1(struct snd_platform_data *pdata);
>  
> +void dm646x_video_init(void);
> +
> +struct vpif_output {
> +     u16 id;
> +     const char *name;
> +};
> +
> +struct subdev_info {
> +     unsigned short addr;
> +     const char *name;
> +};

'subdev_info' is far too generic to have in platform header files.
Please rename this to at least vpif_subdev_info.

Other than that, patch looks fine.
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to