Hi all,

Since 4.8-rc1, I am getting WARN-s when trying to capture from an AverMedia Hybrid+FM DVB-T card using dvbstream:


------------[ cut here ]------------
WARNING: CPU: 0 PID: 1889 at ../drivers/media/v4l2-core/videobuf2-dma-sg.c:107 vb2_dma_sg_alloc+0x284/0x4d0 [videobuf2_dma_sg] Modules linked in: nf_log_ipv6 xt_pkttype nf_log_ipv4 nf_log_common xt_LOG xt_limit af_packet iscsi_ibft iscsi_boot_sysfs ip6t_REJECT nf_reject_ip CPU: 0 PID: 1889 Comm: dvbstream Not tainted 4.8.0-rc1-0.gf3b2ad2-default #1 Hardware name: Gigabyte Technology Co., Ltd. B85-HD3/B85-HD3, BIOS F2 07/04/2014
 0000000000000000 ffffffff813a2792 0000000000000000 0000000000000000
 ffffffff8107daee ffff8802157fba08 0000000000000000 0000000000000002
 ffff8802157fb828 ffff8801ff3ab818 0000000000000000 ffffffffa02eddb4
Call Trace:
 [<ffffffff8102ef0e>] dump_trace+0x5e/0x310
 [<ffffffff8102f2db>] show_stack_log_lvl+0x11b/0x1a0
 [<ffffffff81030011>] show_stack+0x21/0x40
 [<ffffffff813a2792>] dump_stack+0x5c/0x7a
 [<ffffffff8107daee>] __warn+0xbe/0xe0
 [<ffffffffa02eddb4>] vb2_dma_sg_alloc+0x284/0x4d0 [videobuf2_dma_sg]
 [<ffffffffa0502a61>] __vb2_queue_alloc+0x161/0x3f0 [videobuf2_core]
 [<ffffffffa0502e70>] vb2_core_reqbufs+0x180/0x380 [videobuf2_core]
 [<ffffffffa0503271>] __vb2_init_fileio+0xd1/0x2e0 [videobuf2_core]
 [<ffffffffa0503c0e>] vb2_thread_start+0x8e/0x150 [videobuf2_core]
 [<ffffffffa02f21ab>] vb2_dvb_start_feed+0x6b/0x90 [videobuf2_dvb]
 [<ffffffffa052697b>] dmx_ts_feed_start_filtering+0x5b/0xf0 [dvb_core]
 [<ffffffffa05247d2>] dvb_dmxdev_start_feed.isra.5+0xa2/0xe0 [dvb_core]
 [<ffffffffa0524894>] dvb_dmxdev_filter_start+0x84/0x3a0 [dvb_core]
 [<ffffffffa05252e0>] dvb_demux_do_ioctl+0x2a0/0x530 [dvb_core]
 [<ffffffffa05237d1>] dvb_usercopy+0x51/0x160 [dvb_core]
 [<ffffffffa0523cd1>] dvb_demux_ioctl+0x11/0x20 [dvb_core]
 [<ffffffff8122b700>] do_vfs_ioctl+0x90/0x5c0
 [<ffffffff8122bca4>] SyS_ioctl+0x74/0x80
 [<ffffffff816d1d36>] entry_SYSCALL_64_fastpath+0x1e/0xa8
DWARF2 unwinder stuck at entry_SYSCALL_64_fastpath+0x1e/0xa8

Leftover inexact backtrace:

---[ end trace 441c231b428d24a2 ]---

The above backtrace is for a SuSE kernel, but the same happens for vanilla kernels as well.

Full dmesg is attached in the relevant kernel bugzilla entry:

https://bugzilla.kernel.org/show_bug.cgi?id=156751

Any idea what can cause this?

Thanks,
Marton
--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to