I am using a ASUS netbook with a USB 2.0 web camera (04f2:b071 Chicony
Electronics Co., Ltd 2.0M UVC WebCam / CNF7129)
I installed Linux, and the default uvcvideo.ko works (I tried
gstreamer-properties, which can find CNF7129 device and show correct
video camera test).
While I want to try the newest V4L2 build, So I follow
http://www.linuxtv.org/wiki to:
1: get the src code v4l-dvb-9652f85e688a.tar.gz
2: make and make install on my netbook.
3: reboot system

lsmod shows me uvcvideo module has been loaded, while
gstreamer-properties can't find CNF7129 device, so I can't use this
USB 2.0 web camera now.

I also tried re-install original workable Linux, and make v4l again.
Then copy the newly build uvcvideo.ko to
module still can be found from lsmod, while gstreamer-properties still
can't find CNF7129 device.

Does it mean I must do some code modification for 04f2:b071 device
before I build v4l driver?


-----------------------------Here is lsusb -v information of my
Bus 001 Device 004: ID 04f2:b071 Chicony Electronics Co., Ltd 2.0M UVC
WebCam / CNF7129
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          239 Miscellaneous Device
  bDeviceSubClass         2 ?
  bDeviceProtocol         1 Interface Association
  bMaxPacketSize0        64
  idVendor           0x04f2 Chicony Electronics Co., Ltd
  idProduct          0xb071 2.0M UVC WebCam / CNF7129
  bcdDevice           15.44
  iManufacturer           2 Chicony Electronics Co., Ltd.
  iProduct                1 CNF7129
  iSerial                 3 SN0001
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to