2012/1/31 Kenni Lund <ke...@kelu.dk>:
> Hi list
> I'm unable to get the CI working on a TT CT-3650 with a Viaccess CAM.
> Every time the CAM is inserted, I get a "dvb_ca adapter 0: Invalid PC
> card inserted :(" error message.
> I've tested with both an Arch Linux 3.2.1 kernel (CI-support included)
> and with a Ubuntu 2.6.32 kernel with latest media_build git compiled
> against it - both results in the same error.
> To rule out any hardware issues, I've tested the tuner with the
> Viaccess CAM under Windows, and it works without any issues here.
> From my very limited understanding of the code, it appears that the
> CAM never returns any initialization string to the driver - or times
> out too early - and therefore never is initialized ("TUPLE type:0x0
> length:0").

For the sake of the archives, I finally got it working. Jose Alberto
Reguero was kind enough to tell me, that the above error message is
simply caused by the CAM being in sleep-mode. When an application
needs it, the CAM *should* wake up and initialize successfully. In my
case it didn't on multiple test setups, but it works now on my test
system with the following software:
- A daily build of Ubuntu 12.04 (~alpha2) which includes a 3.2 kernel.
- A daily build of MythTV pre0.25.
- A quick workaround with hard links added to /etc/rc.local to make up
for the non-existing /dev/dvb/adapter0/*1 devices on the combined
DVB-C/T tuner:
ln -s /dev/dvb/adapter0/ca0 /dev/dvb/adapter0/ca1
ln -s /dev/dvb/adapter0/demux0 /dev/dvb/adapter0/demux1
ln -s /dev/dvb/adapter0/dvr0 /dev/dvb/adapter0/dvr1
ln -s /dev/dvb/adapter0/net0 /dev/dvb/adapter0/net1

With this setup, the CAM initializes correctly once the MythTV backend
is started on bootup.

Best regards
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to