Hi Steffen,

On 2013-01-25 11:01, Steffen Trumtrar wrote:

> +/* VESA display monitor timing parameters */
> +#define VESA_DMT_HSYNC_LOW           BIT(0)
> +#define VESA_DMT_HSYNC_HIGH          BIT(1)
> +#define VESA_DMT_VSYNC_LOW           BIT(2)
> +#define VESA_DMT_VSYNC_HIGH          BIT(3)
> +
> +/* display specific flags */
> +#define DISPLAY_FLAGS_DE_LOW         BIT(0)  /* data enable flag */
> +#define DISPLAY_FLAGS_DE_HIGH                BIT(1)
> +#define DISPLAY_FLAGS_PIXDATA_POSEDGE        BIT(2)  /* drive data on pos. 
> edge */
> +#define DISPLAY_FLAGS_PIXDATA_NEGEDGE        BIT(3)  /* drive data on neg. 
> edge */
> +#define DISPLAY_FLAGS_INTERLACED     BIT(4)
> +#define DISPLAY_FLAGS_DOUBLESCAN     BIT(5)

<snip>

> +     unsigned int dmt_flags; /* VESA DMT flags */
> +     unsigned int data_flags; /* video data flags */

Why did you go for this approach? To be able to represent
true/false/not-specified?

Would it be simpler to just have "flags" field? What does it give us to
have those two separately?

Should the above say raising edge/falling edge instead of positive
edge/negative edge?

 Tomi

--
To unsubscribe from this list: send the line "unsubscribe linux-media" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to