I ordered an HVR850 USB TV tuner, planning to use it with an NTSC cable input. 
The LinuxTV.org page 
<http://www.linuxtv.org/wiki/index.php/Hauppauge_WinTV-HVR-850> said that there 
were three different models, so I checked and mine is 2040:b140... the last one 
to be supported. A discussion post 
 there said that the card was working as of 2013 but my experience has been 
closer to these ones:


Since it was my first time using v4l, I didn't know what modules to load. Upon 
inserting the tuner, I saw 16 new modules autoloaded: media, tuner, videodev, 
videobuf_core, videobuf_vmalloc, v4l2_common, rc_core, cx25840, cx2341x, 
cx231xx, cx231xx_alsa, cx231xx_dvb, dvb_core, tda18271, tea5767, lgdt3305. This 
creates a few new device nodes:


The ones with asterisk are only created sometimes. The dmesg output was quite 
problematic (first_dmesg <http://paste.ubuntu.com/6555061/>) and I later found 
out this was because of lgdt3305_attach() and tda18271_attach(). If I 
explicitly modprobe lgdt3305 and tda18271 before inserting the tuner, I get 
something better (second_dmesg <http://paste.ubuntu.com/6555075/>). However, 
one troubling thing is __tda18271_write_regs failing with -32. This is probably 
the very first call to __tda18271_write_regs being done in 
tda18271_init_regs(). So the registers on this chip that is essential to use 
the analog part of the tuner are not initialized. When I try to actually use 
the tuner, the same error appears again (third_dmesg 

I was testing it with the command "mplayer -tv 
driver=v4l2:device=/dev/video0:norm=NTSC:chanlist=us-cable tv://" and seeing a 
green screen. But I also see a black screen when using xawtv and a 0 byte file 
when using "cat /dev/video0 > foo". I tried a few different machines and kernel 

Some people have suggested patches. One was a user named Jimbo on 
http://www.kernellabs.com/blog/?p=1445 (I'm guessing the polaris4 link is 
broken because that was merged to mailine?) Anyway he said that 
HAUPPAUGE_USBLIVE2 workarounds for error -71 might need to be there for 
HAUPPAUGE_EXETER. I tried this and it didn't work. One person who blogged about 
trouble with the HAUPPAUGE_USBLIVE2 
 said it was fixed by getting rid of a "value |= (1 << 7)". I tried this and it 
also didn't work.

Before I dangerously try any more patches when I don't know what they do... do 
you guys know how to fix this?

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to