linux-modules
Thread
Date
Earlier messages
Messages by Thread
Re: [PATCH 2/3] rust: sync: add SetOnce::try_get_or_populate()
sashiko-bot
Re: [PATCH 1/3] rust: sync: return `Result<&T, T>` from `SetOnce::populate()`
sashiko-bot
Re: [PATCH 1/5] module/dups: Fix use-after-free in kmod_dup_req lifetime handling
sashiko-bot
Re: [PATCH 1/5] module/dups: Fix use-after-free in kmod_dup_req lifetime handling
Petr Pavlu
Re: [PATCH 5/5] module/dups: Clean up includes
sashiko-bot
Re: [PATCH 2/5] module/dups: Inform duplicate requests about the result directly
sashiko-bot
Re: [PATCH 3/5] module/dups: Use scoped guards for kmod_dup_mutex
sashiko-bot
Re: [PATCH 3/5] module/dups: Use scoped guards for kmod_dup_mutex
Petr Pavlu
Re: [PATCH v6 2/2] module: Rename module_blacklist to module_denylist
sashiko-bot
Re: [PATCH v5 1/2] module: Extend module_blacklist parameter to built-in modules
sashiko-bot
Re: [PATCH v5 2/2] module: Rename module_blacklist to module_denylist
sashiko-bot
Re: [PATCH] module: fix UAF and GPF in idempotent_init_module via heap allocation
sashiko-bot
Re: [PATCH v7 4/4] kallsyms: add KUnit tests for lineinfo feature
sashiko-bot
Re: [PATCH v7 2/4] kallsyms: extend lineinfo to loadable modules
sashiko-bot
Re: [PATCH v7 1/4] kallsyms: embed source file:line info in kernel stack traces
sashiko-bot
Re: About THIS_MODULE
Petr Pavlu
Re: [PATCH] module: validate string table section types
sashiko-bot
Re: [PATCH 3/4] tpm_crb_ffa: Include linux/slab.h for kzalloc_obj() and kfree()
sashiko-bot
Re: [PATCH 3/4] tpm_crb_ffa: Include linux/slab.h for kzalloc_obj() and kfree()
Petr Pavlu
Re: [PATCH v6 3/4] kallsyms: delta-compress lineinfo tables for ~2.7x size reduction
sashiko-bot
Re: [PATCH v6 4/4] kallsyms: add KUnit tests for lineinfo feature
sashiko-bot
Re: [PATCH v6 1/4] kallsyms: embed source file:line info in kernel stack traces
sashiko-bot
Re: [PATCH v6 2/4] kallsyms: extend lineinfo to loadable modules
sashiko-bot
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Sebastian Andrzej Siewior
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Petr Pavlu
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Paul E. McKenney
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Sebastian Andrzej Siewior
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Paul E. McKenney
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Sebastian Andrzej Siewior
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Petr Pavlu
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Sebastian Andrzej Siewior
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Sebastian Andrzej Siewior
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Paul E. McKenney
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Sebastian Andrzej Siewior
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Paul E. McKenney
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Sebastian Andrzej Siewior
Re: [PATCH net v2] ppp: defer channel free to an RCU grace period to fix pppol2tp RX UAF
Paul E. McKenney
Re: [PATCH v3] module: Extend module_blacklist parameter to built-in modules
sashiko-bot
Re: [PATCH v5] rust: configfs: add procedural macro for declaring configfs attributes
sashiko-bot
Re: [PATCH v2] module: Extend module_blacklist parameter to built-in modules
sashiko-bot
[PATCH v3 0/7] Prepare mutable list iterators to cache cursor state
Kaitao Cheng
[PATCH v3 1/7] list: Add mutable iterator variants
Kaitao Cheng
Re: [PATCH v3 1/7] list: Add mutable iterator variants
David Laight
Re: [PATCH v3 1/7] list: Add mutable iterator variants
Kaitao Cheng
Re: [PATCH v3 1/7] list: Add mutable iterator variants
Christian König
Re: [PATCH v3 1/7] list: Add mutable iterator variants
David Laight
Re: [PATCH v3 1/7] list: Add mutable iterator variants
Kaitao Cheng
Re: [PATCH v3 1/7] list: Add mutable iterator variants
Jani Nikula
Re: [PATCH v3 1/7] list: Add mutable iterator variants
Kaitao Cheng
Re: [PATCH v3 1/7] list: Add mutable iterator variants
Christian König
[PATCH v3 2/7] llist: Add mutable iterator variants
Kaitao Cheng
[PATCH v3 5/7] kernel: Use mutable list iterators
Kaitao Cheng
Re: [PATCH v3 5/7] kernel: Use mutable list iterators
bot+bpf-ci
Re: [PATCH v3 5/7] kernel: Use mutable list iterators
Eduard Zingerman
Re: [PATCH v3 0/7] Prepare mutable list iterators to cache cursor state
Alexei Starovoitov
Re: [PATCH v3 0/7] Prepare mutable list iterators to cache cursor state
Kaitao Cheng
Re: [PATCH v3 0/7] Prepare mutable list iterators to cache cursor state
Andy Shevchenko
Re: [PATCH v3 0/7] Prepare mutable list iterators to cache cursor state
Kaitao Cheng
Re: [PATCH v3 0/7] Prepare mutable list iterators to cache cursor state
David Hildenbrand (Arm)
Re: [PATCH v3 0/7] Prepare mutable list iterators to cache cursor state
Kaitao Cheng
Re: [PATCH v3 0/7] Prepare mutable list iterators to cache cursor state
Jani Nikula
Re: [PATCH v3 0/7] Prepare mutable list iterators to cache cursor state
Kaitao Cheng
Re: [PATCH v4] rust: configfs: add procedural macro for declaring configfs attributes
sashiko-bot
Re: [PATCH v3] rust: add procedural macro for declaring configfs attributes
sashiko-bot
[PATCH v2] module: procfs: fix signed integer overflow in module_total_size()
Naveen Kumar Chaudhary
Re: [PATCH v2] module: procfs: fix signed integer overflow in module_total_size()
Petr Pavlu
Re: [PATCH v2] module: procfs: fix signed integer overflow in module_total_size()
Sami Tolvanen
Re: [PATCH v2] module: procfs: fix signed integer overflow in module_total_size()
Petr Pavlu
[PATCH v2] module: use strscpy() to copy module names in stats and dup tracking
Naveen Kumar Chaudhary
Re: [PATCH v2] module: use strscpy() to copy module names in stats and dup tracking
sashiko-bot
Re: [PATCH v2] module: use strscpy() to copy module names in stats and dup tracking
Petr Pavlu
Re: [PATCH v2] module: use strscpy() to copy module names in stats and dup tracking
Petr Pavlu
Re: [PATCH 1/2] xtensa/simdisk: Avoid referring to module::args
sashiko-bot
Re: [PATCH] module: dups: use strscpy() to copy module name in dup request
sashiko-bot
Re: [PATCH v4 18/25] dyndbg: Upgrade class param storage to u64 for 64-bit classmaps
sashiko-bot
Re: [PATCH v4 22/25] selftests-dyndbg: add a dynamic_debug run_tests target
sashiko-bot
Re: [PATCH v4 12/25] dyndbg: drop NUM_TYPE_ARGS
sashiko-bot
Re: [PATCH v4 11/25] dyndbg-API: remove DD_CLASS_TYPE_(DISJOINT|LEVEL)_NAMES and code
sashiko-bot
Re: [PATCH v4 16/25] dyndbg: replace classmap list with an array-slice
sashiko-bot
[PATCH] module: dups: don't hold mutex across synchronize_rcu()
Naveen Kumar Chaudhary
Re: [PATCH] module: dups: don't hold mutex across synchronize_rcu()
sashiko-bot
Re: [PATCH] module: dups: don't hold mutex across synchronize_rcu()
Petr Pavlu
Re: [PATCH v3 24/24] dynamic_debug: use KBUILD_MODFILE for unique builtin module names
sashiko-bot
Re: [PATCH v3 18/24] dyndbg: Upgrade class param storage to u64 for 64-bit classmaps
sashiko-bot
Re: [PATCH v3 19/24] dyndbg,module: make proper substructs in _ddebug_info
sashiko-bot
Re: [PATCH v3 13/24] dyndbg: reduce verbose/debug clutter
sashiko-bot
Re: [PATCH v3 22/24] selftests-dyndbg: add a dynamic_debug run_tests target
sashiko-bot
Re: [PATCH v2] rust: module_param: return value by copy from `value`
sashiko-bot
Re: [PATCH v3] ARM: module.lds: fix unwind metadata for merged .text sections
sashiko-bot
Re: [PATCH v2] ARM: module.lds: fix unwind metadata for merged .text sections
sashiko-bot
Re: [PATCH] rust: module_param: return value by copy from `value`
sashiko-bot
Re: [PATCH v2 21/24] dyndbg: hoist classmap-filter-by-modname up to ddebug_add_module
sashiko-bot
Re: [PATCH v2 19/24] dyndbg,module: make proper substructs in _ddebug_info
sashiko-bot
Re: [PATCH v2 18/24] dyndbg: Upgrade class param storage to u64 for 64-bit classmaps
sashiko-bot
Re: [PATCH v2 05/24] vmlinux.lds.h: Fix ALIGN(8) omission causing NULL ptr on i386
sashiko-bot
Re: [PATCH v2 16/24] dyndbg: replace classmap list with an array-slice
sashiko-bot
Re: [PATCH v2 22/24] selftests-dyndbg: add a dynamic_debug run_tests target
sashiko-bot
Re: [PATCH v2 11/24] dyndbg-API: remove DD_CLASS_TYPE_(DISJOINT|LEVEL)_NAMES and code
sashiko-bot
Re: [PATCH v2 12/24] dyndbg: drop NUM_TYPE_ARGS
sashiko-bot
Re: [PATCH v2 13/24] dyndbg: reduce verbose/debug clutter
sashiko-bot
[PATCH 00/11] Convert moduleparams to seq_buf
Kees Cook
[PATCH 11/11] moduleparam: Drop legacy kernel_param_ops .get_str field and dispatch logic
Kees Cook
[PATCH 03/11] moduleparam: Add DEFINE_KERNEL_PARAM_OPS macro family
Kees Cook
Re: [PATCH 03/11] moduleparam: Add DEFINE_KERNEL_PARAM_OPS macro family
Petr Pavlu
[PATCH 02/11] panic: Replace panic_print_get() with generic helper
Kees Cook
[PATCH 05/11] moduleparam: Rename .get field to .get_str
Kees Cook
[PATCH 06/11] moduleparam: Add seq_buf-based .get callback alongside .get_str
Kees Cook
Re: [PATCH 06/11] moduleparam: Add seq_buf-based .get callback alongside .get_str
Petr Pavlu
[PATCH 07/11] moduleparam: Route DEFINE_KERNEL_PARAM_OPS get pointer via _Generic
Kees Cook
Re: [PATCH 07/11] moduleparam: Route DEFINE_KERNEL_PARAM_OPS get pointer via _Generic
Petr Pavlu
[PATCH 08/11] params: Convert generic kernel_param_ops .get helpers to seq_buf
Kees Cook
Re: [PATCH 08/11] params: Convert generic kernel_param_ops .get helpers to seq_buf
Petr Pavlu
[PATCH 01/11] params: bound array element output to the caller's page buffer
Kees Cook
Re: [PATCH 01/11] params: bound array element output to the caller's page buffer
David Laight
Re: [PATCH 01/11] params: bound array element output to the caller's page buffer
Matthew Wilcox
Re: [PATCH 01/11] params: bound array element output to the caller's page buffer
Andy Shevchenko
Re: [PATCH 01/11] params: bound array element output to the caller's page buffer
Jason Gunthorpe
Re: [PATCH 01/11] params: bound array element output to the caller's page buffer
David Laight
[PATCH 04/11] treewide: Convert struct kernel_param_ops initializers to DEFINE_KERNEL_PARAM_OPS
Kees Cook
Re: [PATCH 04/11] treewide: Convert struct kernel_param_ops initializers to DEFINE_KERNEL_PARAM_OPS
Sean Christopherson
Re: [PATCH 04/11] treewide: Convert struct kernel_param_ops initializers to DEFINE_KERNEL_PARAM_OPS
Rafael J. Wysocki
Re: [PATCH 04/11] treewide: Convert struct kernel_param_ops initializers to DEFINE_KERNEL_PARAM_OPS
SeongJae Park
Re: [PATCH 04/11] treewide: Convert struct kernel_param_ops initializers to DEFINE_KERNEL_PARAM_OPS
Petr Pavlu
Re: [PATCH 04/11] treewide: Convert struct kernel_param_ops initializers to DEFINE_KERNEL_PARAM_OPS
jim . cromie
[PATCH 09/11] treewide: Convert custom kernel_param_ops .get callbacks to seq_buf via cocci
Kees Cook
Re: [PATCH 09/11] treewide: Convert custom kernel_param_ops .get callbacks to seq_buf via cocci
Sean Christopherson
Re: [PATCH 09/11] treewide: Convert custom kernel_param_ops .get callbacks to seq_buf via cocci
Rafael J. Wysocki
Re: [PATCH 09/11] treewide: Convert custom kernel_param_ops .get callbacks to seq_buf via cocci
SeongJae Park
[PATCH 10/11] treewide: Manually convert custom kernel_param_ops .get callbacks
Kees Cook
Re: [PATCH 10/11] treewide: Manually convert custom kernel_param_ops .get callbacks
Jani Nikula
Re: [PATCH 10/11] treewide: Manually convert custom kernel_param_ops .get callbacks
Rafael J. Wysocki
Re: [PATCH 00/11] Convert moduleparams to seq_buf
Petr Pavlu
Re: [PATCH 00/11] Convert moduleparams to seq_buf
Kees Cook
[PATCH v14 00/92] dyndbg: enable 0-off-cost for all of __drm_debug
Jim Cromie
[PATCH v14 03/92] dyndbg.lds.S: fix lost dyndbg sections in modules
Jim Cromie
[PATCH v14 08/92] docs/dyndbg: explain flags parse 1st
Jim Cromie
[PATCH v14 09/92] test-dyndbg: fixup CLASSMAP usage error
Jim Cromie
[PATCH v14 10/92] dyndbg: reword "class unknown," to "class:_UNKNOWN_"
Jim Cromie
[PATCH v14 11/92] dyndbg: make ddebug_class_param union members same size
Jim Cromie
[PATCH v14 12/92] dyndbg: drop NUM_TYPE_ARRAY
Jim Cromie
[PATCH v14 01/92] dyndbg: fix NULL ptr on i386 due to section mis-alignment
Jim Cromie
[PATCH v14 02/92] vmlinux.lds.h: move BOUNDED_SECTION_* macros to reuse later
Jim Cromie
[PATCH v14 18/92] dyndbg: macrofy a 2-index for-loop pattern
Jim Cromie
[PATCH v14 19/92] dyndbg,module: make proper substructs in _ddebug_info
Jim Cromie
[PATCH v14 04/92] vmlinux.lds.h: drop unused HEADERED_SECTION* macros
Jim Cromie
[PATCH v14 06/92] dyndbg: add stub macro for DECLARE_DYNDBG_CLASSMAP
Jim Cromie
[PATCH v14 13/92] dyndbg: tweak pr_fmt to avoid expansion conflicts
Jim Cromie
[PATCH v14 14/92] dyndbg: reduce verbose/debug clutter
Jim Cromie
[PATCH v14 16/92] dyndbg: tighten fn-sig of ddebug_apply_class_bitmap
Jim Cromie
[PATCH v14 05/92] dyndbg: factor ddebug_match_desc out from ddebug_change
Jim Cromie
[PATCH v14 07/92] docs/dyndbg: update examples \012 to \n
Jim Cromie
[PATCH v14 15/92] dyndbg: refactor param_set_dyndbg_classes and below
Jim Cromie
[PATCH v14 17/92] dyndbg: replace classmap list with a vector
Jim Cromie
Re: [RFC PATCH 1/2] kernel/notifier: replace single-linked list with double-linked list for reverse traversal
Christoph Hellwig
Re: [RFC PATCH 1/2] kernel/notifier: replace single-linked list with double-linked list for reverse traversal
Petr Mladek
Re: [RFC PATCH 1/2] kernel/notifier: replace single-linked list with double-linked list for reverse traversal
David Laight
Re: [RFC PATCH 1/2] kernel/notifier: replace single-linked list with double-linked list for reverse traversal
Petr Mladek
Re: [RFC PATCH 1/2] kernel/notifier: replace single-linked list with double-linked list for reverse traversal
David Laight
Re: [RFC PATCH 1/2] kernel/notifier: replace single-linked list with double-linked list for reverse traversal
Google
Re: [RFC PATCH 1/2] kernel/notifier: replace single-linked list with double-linked list for reverse traversal
Petr Mladek
Re: [RFC PATCH 1/2] kernel/notifier: replace single-linked list with double-linked list for reverse traversal
Song Chen
Re: [RFC PATCH 1/2] kernel/notifier: replace single-linked list with double-linked list for reverse traversal
Song Chen
Re: [RFC PATCH 0/2] Decouple ftrace/livepatch from module loader via notifier priority and reverse traversal
Christoph Hellwig
Re: [RFC PATCH 2/2] kernel/module: Decouple klp and ftrace from load_module
Petr Pavlu
Re: [RFC PATCH 2/2] kernel/module: Decouple klp and ftrace from load_module
Petr Pavlu
Re: [RFC PATCH 2/2] kernel/module: Decouple klp and ftrace from load_module
Petr Mladek
Re: [RFC PATCH 2/2] kernel/module: Decouple klp and ftrace from load_module
Google
Re: [RFC PATCH 2/2] kernel/module: Decouple klp and ftrace from load_module
Song Chen
Re: [RFC PATCH 2/2] kernel/module: Decouple klp and ftrace from load_module
Petr Mladek
[PATCH] tracing: preserve module tracepoint strings
Cao Ruichuang
Re: [PATCH] tracing: preserve module tracepoint strings
Steven Rostedt
Re: [PATCH] tracing: preserve module tracepoint strings
Petr Pavlu
[RFC PATCH] modules: extend {kstrdup,kfree}_const() to handle per-module .rodata
Dmitry Antipov
[PATCH v2 1/2] module/kallsyms: fix nextval for data symbol lookup
Stanislaw Gruszka
[PATCH v2 2/2] module/kallsyms: sort function symbols and use binary search
Stanislaw Gruszka
Re: [PATCH v2 2/2] module/kallsyms: sort function symbols and use binary search
Petr Pavlu
Re: [PATCH v2 2/2] module/kallsyms: sort function symbols and use binary search
Petr Pavlu
Re: [PATCH v2 2/2] module/kallsyms: sort function symbols and use binary search
Petr Mladek
Re: [PATCH v2 2/2] module/kallsyms: sort function symbols and use binary search
Petr Pavlu
Re: [PATCH v2 2/2] module/kallsyms: sort function symbols and use binary search
Petr Mladek
Re: [PATCH v2 2/2] module/kallsyms: sort function symbols and use binary search
Petr Pavlu
Re: [PATCH v2 1/2] module/kallsyms: fix nextval for data symbol lookup
Petr Pavlu
Re: [PATCH v2 1/2] module/kallsyms: fix nextval for data symbol lookup
Petr Pavlu
[PATCH] module/kallsyms: sort function symbols and use binary search
Stanislaw Gruszka
Re: [PATCH] module/kallsyms: sort function symbols and use binary search
Petr Pavlu
Re: [PATCH] module/kallsyms: sort function symbols and use binary search
Petr Pavlu
[PATCH v11 22/65] dyndbg-API: replace DECLARE_DYNDBG_CLASSMAP
Jim Cromie
[PATCH v11 16/65] dyndbg,module: make proper substructs in _ddebug_info
Jim Cromie
[PATCH v2 0/2] kthread, exit: clean up kernel thread exit paths
Christian Brauner
[PATCH v2 2/2] tree-wide: rename do_exit() to task_exit()
Christian Brauner
Re: [PATCH v2 2/2] tree-wide: rename do_exit() to task_exit()
Frederic Weisbecker
Re: [PATCH v2 2/2] tree-wide: rename do_exit() to task_exit()
Steven Rostedt
[PATCH v2 1/2] kthread: remove kthread_exit()
Christian Brauner
Re: [PATCH v2 1/2] kthread: remove kthread_exit()
Frederic Weisbecker
Re: [PATCH v2 1/2] kthread: remove kthread_exit()
David Laight
Re: [PATCH v2 1/2] kthread: remove kthread_exit()
Steven Rostedt
[PATCH 00/61] treewide: Use IS_ERR_OR_NULL over manual NULL check - refactor
Philipp Hahn
[PATCH 16/61] sched: Prefer IS_ERR_OR_NULL over manual NULL check
Philipp Hahn
RE: [Intel-wired-lan] [PATCH 16/61] sched: Prefer IS_ERR_OR_NULL over manual NULL check
Loktionov, Aleksandr
[PATCH 13/61] squashfs: Prefer IS_ERR_OR_NULL over manual NULL check
Philipp Hahn
Earlier messages