On Mon, Apr 16, 2018 at 2:27 PM, Vishal Verma <[email protected]> wrote: > For boot support efibootmgr needs to be able to lookup up the raw > namespace uuid to match the device-path that EFI emits. By default > 'ndctl list' displays the uuid that is present in the address > abstraction info-block. Add a "raw_uuid" so that tooling can > correlate the default uuid with the base uuid for the namespace. > > Cc: Dan Williams <[email protected]> > Signed-off-by: Vishal Verma <[email protected]> > --- > util/json.c | 23 +++++++++++++++++++++++ > 1 file changed, 23 insertions(+) > > diff --git a/util/json.c b/util/json.c > index 8d65525..efad8f7 100644 > --- a/util/json.c > +++ b/util/json.c > @@ -650,6 +650,17 @@ static struct json_object > *util_dax_badblocks_to_json(struct ndctl_dax *dax, > bb_count, flags); > } > > +static struct json_object *util_raw_uuid(struct ndctl_namespace *ndns) > +{ > + struct json_object *jobj; > + uuid_t raw_uuid; > + char buf[40]; > + > + ndctl_namespace_get_uuid(ndns, raw_uuid); > + uuid_unparse(raw_uuid, buf); > + return json_object_new_string(buf); > +} > +
I don't mind this new helper, but it seems out of place given all the other uuid-to-json-string conversions are open-coded in util_namespace_to_json(). Let's just open-code like all the rest, and maybe follow on with a global cleanup to use a helper in a later patch. However, I'm not sure it will be worth it / a net code reduction. _______________________________________________ Linux-nvdimm mailing list [email protected] https://lists.01.org/mailman/listinfo/linux-nvdimm
