On 12/12/19 7:33 AM, Liran Alon wrote:
+       /*
+        * Our caller grabbed the KVM mmu_lock with a successful
+        * mmu_notifier_retry, so we're safe to walk the page table.
+        */
+       switch (dev_pagemap_mapping_shift(hva, current->mm)) {
Doesn’t dev_pagemap_mapping_shift() get “struct page” as first parameter?
Was this changed by a commit I missed?

I changed this in Patch 1. The place I call it in KVM has the address and mm available, which is the only think dev_pagemap_mapping_shift() really needs. (The first thing it did was convert page to address).

I'll add some more text to patch 1's commit message about that.

Thanks,

Barret

_______________________________________________
Linux-nvdimm mailing list -- [email protected]
To unsubscribe send an email to [email protected]

Reply via email to