> > +/* Dummy regulator for pwm-backlight driver */ static struct
> > +regulator_consumer_supply backlight_supply =
> > + REGULATOR_SUPPLY("enable", NULL);
>
> 'enable' is just too generic, the device name should be also provided:
> REGULATOR_SUPPLY("enable", "pwm-backlight");
You're right. I don't like how generic it is as well. But I don't think
"pwm-backlight" works...at least, not for me when I test it. What
does work is "backlight.x" where x is some number (for me, it's 1).
Problem is, I don't know what it would be for you. If only there
was a way to wildcard that...
Would it be better if we called the regulator something other than
"enable"? Maybe "backlight-enable", or "bl-enable" for brevity?
--
To unsubscribe from this list: send the line "unsubscribe linux-omap" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html