On Mon, 2010-08-16 at 20:55 +0200, Bart Van Assche wrote: > Implements SRP_CRED_REQ and SRP_AER_REQ, which are information units defined > in the SRP (draft) standard. Adds declarations for the SRP_CRED_REQ, > SRP_CRED_RSP, SRP_AER_REQ and SRP_AER_RSP information units to > include/scsi/srp.h. Changes function definition order in ib_srp in order to > avoid having to add more forward declarations.
I still don't like the style of this patch -- too much code duplication and the SRP_TX_IU_* constants are too ugly to live. I'd also prefer to put the code movement in a separate patch, so in this case I'd accept the forward declaration and we can do a separate patch later to move the code around in one swoop. I think there's quite a bit that can potentially be cleaned up there, and I don't expect you to do it as part of this series. In that light, do you have any technical comment on the version I posted? It is my preference to go with that version. Dave -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of a message to [email protected] More majordomo info at http://vger.kernel.org/majordomo-info.html
