> On 8/15/2012 12:54 AM, Jason Gunthorpe wrote: > > On Tue, Aug 14, 2012 at 09:39:23PM +0000, Hefty, Sean wrote: > >>> +#define if_PF(cond) if(CL_PREDICT_FALSE(cond)) > >>> +#define if_PT(cond) if(CL_PREDICT_TRUE(cond)) > >> > >> If CL_PREDICT_TRUE/FALSE are too long, why not just shorten those, > >> rather than abstract if statements behind a macro? > > It's not the size - it's just the readability of the macro. > First macro (CL_PREDICT_*) is close to the GCC's way to define > it. Second macro (if_PF/T) is close to the usual 'if' statement > syntax.
I would not abstract the 'if' statement. If CL_PREDICT_FALSE/TRUE are not readable, then shorten those. if (PF(...)) is just as readable as if_PF(...) -- To unsubscribe from this list: send the line "unsubscribe linux-rdma" in the body of a message to [email protected] More majordomo info at http://vger.kernel.org/majordomo-info.html
