On Tue, Nov 14, 2017 at 09:59:03AM +0000, Biju Das wrote:
> Add support for r8a7743. The Renesas RZ/G1M(R8A7743)PCIe controller
> is identical to the R-Car Gen2 family.
> 
> No driver change is needed due to the fallback compatible value
> "renesas,pcie-rcar-gen2".
> Adding the SoC-specific compatible values here has three purposes:
> 1. Document which SoCs have this hardware module,
> 2. Allow checkpatch to validate compatible values.
> 3. Allow the driver to support SoC specific implementations in future
>    as necessary.
> 
> Signed-off-by: Biju Das <biju....@bp.renesas.com>
> Reviewed-by: Fabrizio Castro <fabrizio.cas...@bp.renesas.com>
> Reviewed-by: Geert Uytterhoeven <geert+rene...@glider.be>
> ---
> v1-->v2
>    Corrected RZ-G1 to RZ/G1.
> 
>  Documentation/devicetree/bindings/pci/rcar-pci.txt | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)

Applied to pci/rcar for v4.17, apologies for the delay.

Thanks,
Lorenzo

> diff --git a/Documentation/devicetree/bindings/pci/rcar-pci.txt 
> b/Documentation/devicetree/bindings/pci/rcar-pci.txt
> index 76ba3a6..1fb614e 100644
> --- a/Documentation/devicetree/bindings/pci/rcar-pci.txt
> +++ b/Documentation/devicetree/bindings/pci/rcar-pci.txt
> @@ -1,13 +1,15 @@
>  * Renesas R-Car PCIe interface
>  
>  Required properties:
> -compatible: "renesas,pcie-r8a7779" for the R8A7779 SoC;
> +compatible: "renesas,pcie-r8a7743" for the R8A7743 SoC;
> +         "renesas,pcie-r8a7779" for the R8A7779 SoC;
>           "renesas,pcie-r8a7790" for the R8A7790 SoC;
>           "renesas,pcie-r8a7791" for the R8A7791 SoC;
>           "renesas,pcie-r8a7793" for the R8A7793 SoC;
>           "renesas,pcie-r8a7795" for the R8A7795 SoC;
>           "renesas,pcie-r8a7796" for the R8A7796 SoC;
> -         "renesas,pcie-rcar-gen2" for a generic R-Car Gen2 compatible device.
> +         "renesas,pcie-rcar-gen2" for a generic R-Car Gen2 or
> +                                  RZ/G1 compatible device.
>           "renesas,pcie-rcar-gen3" for a generic R-Car Gen3 compatible device.
>  
>           When compatible with the generic version, nodes must list the
> -- 
> 1.9.1
> 

Reply via email to