Hi Kaneko-san,

On 2019-04-18 09:15:14 +0200, Simon Horman wrote:
> From: Yoshihiro Kaneko <ykaneko0...@gmail.com>
> 
> HW manual changes temperature calculation formula for E3:

Is this not also true for V3M and D3?

> - When CTEMP is less than 24
>    T = CTEMP[5:0] * 5.5 - 72
> - When CTEMP is equal to/greater than 24
>    T = CTEMP[5:0] * 5 - 60
> 
> This was inspired by a patch in the BSP by Van Do <van.do...@renesas.com>
> 
> Signed-off-by: Yoshihiro Kaneko <ykaneko0...@gmail.com>
> Tested-by: Simon Horman <horms+rene...@verge.net.au>
> Acked-by: Wolfram Sang <wsa+rene...@sang-engineering.com>
> Signed-off-by: Simon Horman <horms+rene...@verge.net.au>
> ---
>  drivers/thermal/rcar_thermal.c | 11 ++++++++++-
>  1 file changed, 10 insertions(+), 1 deletion(-)
> 
> diff --git a/drivers/thermal/rcar_thermal.c b/drivers/thermal/rcar_thermal.c
> index 97462e9b40d8..11df0cc63bed 100644
> --- a/drivers/thermal/rcar_thermal.c
> +++ b/drivers/thermal/rcar_thermal.c
> @@ -52,6 +52,7 @@ struct rcar_thermal_chip {
>       unsigned int irq_per_ch : 1;
>       unsigned int needs_suspend_resume : 1;
>       unsigned int nirqs;
> +     unsigned int ctemp_bands;

Would it be possible to rename this to something indicating that this is 
a gen3 thing? Maybe move it to the bit fields above and name it gen3 ?

>  };
>  
>  static const struct rcar_thermal_chip rcar_thermal = {
> @@ -60,6 +61,7 @@ static const struct rcar_thermal_chip rcar_thermal = {
>       .irq_per_ch = 0,
>       .needs_suspend_resume = 0,
>       .nirqs = 1,
> +     .ctemp_bands = 1,
>  };
>  
>  static const struct rcar_thermal_chip rcar_gen2_thermal = {
> @@ -68,6 +70,7 @@ static const struct rcar_thermal_chip rcar_gen2_thermal = {
>       .irq_per_ch = 0,
>       .needs_suspend_resume = 0,
>       .nirqs = 1,
> +     .ctemp_bands = 1,
>  };
>  
>  static const struct rcar_thermal_chip rcar_gen3_thermal = {
> @@ -80,6 +83,7 @@ static const struct rcar_thermal_chip rcar_gen3_thermal = {
>        * interrupts to detect a temperature change, rise or fall.
>        */
>       .nirqs = 2,
> +     .ctemp_bands = 2,
>  };
>  
>  struct rcar_thermal_priv {
> @@ -263,7 +267,12 @@ static int rcar_thermal_get_current_temp(struct 
> rcar_thermal_priv *priv,
>               return ret;
>  
>       mutex_lock(&priv->lock);
> -     tmp =  MCELSIUS((priv->ctemp * 5) - 65);
> +     if (priv->chip->ctemp_bands == 1)
> +             tmp =  MCELSIUS((priv->ctemp * 5) - 65);
> +     else if (priv->ctemp < 24)
> +             tmp = MCELSIUS(((priv->ctemp * 55) - 720) / 10);
> +     else
> +             tmp = MCELSIUS((priv->ctemp * 5) - 60);

I confirm that the calculations here are correct, but hard to read ;-) 
With the rename about how about.

    if (priv->chip->gen3) {
        if (priv->ctemp < 24)
                tmp = MCELSIUS(((priv->ctemp * 55) - 720) / 10);
        else
                tmp = MCELSIUS((priv->ctemp * 5) - 60);
    } else {
            tmp =  MCELSIUS((priv->ctemp * 5) - 65);
    }

>       mutex_unlock(&priv->lock);
>  
>       if ((tmp < MCELSIUS(-45)) || (tmp > MCELSIUS(125))) {
> -- 
> 2.11.0
> 

-- 
Regards,
Niklas Söderlund

Reply via email to