Marek Szyprowski wrote:
>
> Hello,
>
Hi all,
[...]
> > static struct s3c_fb_driverdata s3c_fb_data_exynos5 = {
> > .variant = {
> > .nr_windows = 5,
> > - .vidtcon = VIDTCON0,
> > + .vidtcon = FIMD_V8_VIDTCON0,
>
> Yes, this method looks good imo. Maybe even having something like
> vidtcon_base in
> variant structure will be enough to cover all VIDTCON0-3 registers.
>
Yes, I agree. And how about changing the name of s3c_fb_drvierdata to
xxx_fimd_v8 not xxx_fimd_exynos5? It's time to use independent from SoC name
because we don't have any guarantee of same address on all of EXYNOS5 SoCs.
Thanks.
Best regards,
Kgene.
--
Kukjin Kim <[email protected]>, Senior Engineer,
SW Solution Development Team, Samsung Electronics Co., Ltd.
--
To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in
the body of a message to [email protected]
More majordomo info at http://vger.kernel.org/majordomo-info.html