On 6 September 2012 15:43, Tomasz Figa <t.f...@samsung.com> wrote: > Hi Thomas, > > On Thursday 06 of September 2012 14:53:01 Thomas Abraham wrote: >> compatible = "samsung,s3c2440-i2c"; >> reg = <0x13860000 0x100>; >> interrupts = <0 58 0>; >> + pinctrl-names = "default"; >> + pinctrl-0 = <&i2c0_bus>; > > If pinctrl-names property is omitted then the state index is used as a name > (e.g. pinctrl-0 would be named "0"). Maybe it would be better to use this > approach (with respective adjustment in first patch)? What do you think?
I tend to prefer to name the states because it is easier to cross-reference code and dts files. i2c was a simple one, but for mmc controllers, there will 1-bit state, 4-bit state and 8-bit state, and it will be nicer to name then accordingly. So I prefer to use names but if there is wider consensus on not using names, we can drop names. Thanks, Thomas. > > Best regards, > -- > Tomasz Figa > Samsung Poland R&D Center > -- To unsubscribe from this list: send the line "unsubscribe linux-samsung-soc" in the body of a message to majord...@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html