On Tue, Jun 18, 2013 at 10:31:32PM +0900, Akinobu Mita wrote:
>  /**
> + * sg_miter_seek - reposition mapping iterator
> + * @miter: sg mapping iter to be seeked
> + * @offset: number of bytes to plus the current location
> + *
> + * Description:
> + *   Sets the offset of @miter to its current location plus @offset bytes.
> + *
> + * Notes:
> + *   This function must be called just after sg_miter_start() or 
> sg_miter_stop()

It's not gonna be hard to make this function to handle any state,
right?  Wouldn't it be better to do that?  It's a pretty generic
feature after all.  Also, maybe a better name is sg_miter_skip()?

Thanks.

-- 
tejun
--
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to