On 10/18/2016 10:54 AM, Johannes Thumshirn wrote:
> On Tue, Oct 18, 2016 at 10:01:42AM +0200, Hannes Reinecke wrote:
>> The ->rport_create callback only ever had a single implementation,
>> so we can as well call it directly and drop the callback.
>> Signed-off-by: Hannes Reinecke <h...@suse.com>
>> ---
> Any reason we can't rename fc_rport_create() with fc_remote_port_create()
> so the scsi_transport_fc.c patch isn't needed?
Yes: consistency.

Every function in libfc/fc_rport.c is named 'fc_rport_XXX'. So we should
stick to that naming scheme here, too.
scsi_transport_fc.c does not have such a strict naming scheme, so it's
easier to rename that.


Dr. Hannes Reinecke                Teamlead Storage & Networking
h...@suse.de                                   +49 911 74053 688
SUSE LINUX GmbH, Maxfeldstr. 5, 90409 Nürnberg
GF: F. Imendörffer, J. Smithard, J. Guild, D. Upmanyu, G. Norton
HRB 21284 (AG Nürnberg)
To unsubscribe from this list: send the line "unsubscribe linux-scsi" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to