Here is a proposal to use a bsg endpoint to manage ufs devices.

We will do that by adding a bsg device node to the ufs driver,
and use it to send UPIU transactions to the ufs device.
It will serve as a ufs device management infrastructure, 
for device configuration, provisioning, testing and validation, etc.

We added a new ufs-bsg module, and some new API to the ufs driver.

For the time being, we will not use it for data transfer,
but just for device management per-se.
This has nothing to do with the recent removal of bsg read/write support,
we might add this capability in the future,
but it is not our current focus.

We tested it on a Hikey-960 platform with a V4.14 kernel,
"modernized" by recent bsg and ufs patches.
We also used a htc11 with a V4.4 kernel, but needed much more
transport/bsg/ufs patches to make it relevant.

Many thanks to Christoph and Bart for their much appreciated support
and comments.

V5->v6:
Remove the host and device indices from the bsg device name,
as there can be only one.
Use the structure size in pointer arithmetic's instead of 
an opaque 32 bytes for the over allocation of descriptors.
Move ufs_bsg_request and ufs_bsg_reply to include/uapi/scsi/scsi_bsg_ufs.h.
Withdraw from decoding uic command, and just use ufshcd_send_uic_cmd 
Instead.

V4->v5:
use the new lower-level __ufshcd_issue_tm_cmd directly, so
"Allow ufshcd_issue_tm_cmd accept raw upiu" is not needed any more.
Get rid of struct ufs_bsg_node which simplifies ufs_bsg_probe().
Also some small adjustments to v4 fixes.
Have only one length and format for the reply.
Add a documentation of the API as a paragraph in
Documentation/scsi/ufs.txt.

V3->v4:
Squashed the bsg node Instantiation into "Add ufs-bsg".
Build ufs-bsg as part of  ufshcd-core and not as a separate module.
Also merged the ufs_bsg_node into the ufs_hba structure.
Christoph refactored the task management code, cleaning it up 
and making it much more readable - attached as the first 2 patches
In the series.  Afterward passing an external upiu to ufshcd_issue_tm_cmd
Just blends in.

V2->v3:
We dropped the scsi transport code (and changed this patch title
to account for it) as we actually just need the bsg device node.
We also withdraw (brokenhearted) from our intension to create
several bsg devices, and add just one. 
Rephrased the doc in Kconfig.

V1->v2:
Use inline functions instead of defines, and ida to obtain the 
port indices, in scsi_transport_ufs module.
Remove the closing data pointer and __packed notation from
struct ufs_bsg_{request_reply}.
Re-use ufshcd_issue_tm_cmd code - needed a couple of patches for that,
and call req_upiu and rsp_upio with their appropriate struct pointers.
Use a more appropriate name when checking if enough memory
was  allocated for write descriptor, and remove redundant goto.
Add reference to the spec to explain uic command size.
Fix a lot of typos.

Avri Altman (5):
  scsi: ufs: Add ufs-bsg module
  scsi: ufs: Use data structure size in pointer arithmetic
  scsi: ufs: Add API to execute raw upiu commands
  scsi: ufs-bsg: Add support for raw upiu in ufs_bsg_request()
  scsi: ufs-bsg: Add support for uic commands in ufs_bsg_request()

Christoph Hellwig (2):
  scsi: ufs: cleanup struct utp_task_req_desc
  scsi: ufs: add a low-level __ufshcd_issue_tm_cmd helper

 Documentation/scsi/ufs.txt       |  20 +++
 drivers/scsi/ufs/Kconfig         |  19 ++
 drivers/scsi/ufs/Makefile        |   3 +-
 drivers/scsi/ufs/ufs.h           |  94 +---------
 drivers/scsi/ufs/ufs_bsg.c       | 206 ++++++++++++++++++++++
 drivers/scsi/ufs/ufs_bsg.h       |  26 +++
 drivers/scsi/ufs/ufshcd.c        | 367 ++++++++++++++++++++++++++-------------
 drivers/scsi/ufs/ufshcd.h        |  11 ++
 drivers/scsi/ufs/ufshci.h        |  25 +--
 include/uapi/scsi/scsi_bsg_ufs.h | 109 ++++++++++++
 10 files changed, 659 insertions(+), 221 deletions(-)
 create mode 100644 drivers/scsi/ufs/ufs_bsg.c
 create mode 100644 drivers/scsi/ufs/ufs_bsg.h
 create mode 100644 include/uapi/scsi/scsi_bsg_ufs.h

-- 
1.9.1

Reply via email to