linux-trace-kernel
Thread
Date
Earlier messages
Messages by Thread
kprobe on local function
Nam Cao
[PATCH v4 00/39] unwind, perf: sframe user space unwinding
Josh Poimboeuf
[PATCH v4 02/39] task_work: Fix TWA_NMI_CURRENT race with __schedule()
Josh Poimboeuf
Re: [PATCH v4 02/39] task_work: Fix TWA_NMI_CURRENT race with __schedule()
Peter Zijlstra
Re: [PATCH v4 02/39] task_work: Fix TWA_NMI_CURRENT race with __schedule()
Peter Zijlstra
[PATCH v4 01/39] task_work: Fix TWA_NMI_CURRENT error handling
Josh Poimboeuf
Re: [PATCH v4 01/39] task_work: Fix TWA_NMI_CURRENT error handling
Peter Zijlstra
[PATCH v4 03/39] mm: Add guard for mmap_read_lock
Josh Poimboeuf
[PATCH v4 04/39] x86/vdso: Fix DWARF generation for getrandom()
Josh Poimboeuf
[PATCH v4 06/39] x86/asm: Fix VDSO DWARF generation with kernel IBT enabled
Josh Poimboeuf
[PATCH v4 05/39] x86/asm: Avoid emitting DWARF CFI for non-VDSO
Josh Poimboeuf
[PATCH v4 07/39] x86/vdso: Use SYM_FUNC_{START,END} in __kernel_vsyscall()
Josh Poimboeuf
[PATCH v4 08/39] x86/vdso: Use CFI macros in __vdso_sgx_enter_enclave()
Josh Poimboeuf
[PATCH v4 09/39] x86/vdso: Enable sframe generation in VDSO
Josh Poimboeuf
[PATCH v4 11/39] unwind_user: Add user space unwinding API
Josh Poimboeuf
[PATCH v4 10/39] x86/uaccess: Add unsafe_copy_from_user() implementation
Josh Poimboeuf
[PATCH v4 13/39] unwind_user/x86: Enable frame pointer unwinding on x86
Josh Poimboeuf
[PATCH v4 12/39] unwind_user: Add frame pointer support
Josh Poimboeuf
[PATCH v4 14/39] perf/x86: Rename get_segment_base() and make it global
Josh Poimboeuf
Re: [PATCH v4 14/39] perf/x86: Rename get_segment_base() and make it global
Peter Zijlstra
[PATCH v4 15/39] unwind_user: Add compat mode frame pointer support
Josh Poimboeuf
[PATCH v4 17/39] unwind_user/sframe: Add support for reading .sframe headers
Josh Poimboeuf
[PATCH v4 16/39] unwind_user/x86: Enable compat mode frame pointer unwinding on x86
Josh Poimboeuf
[PATCH v4 18/39] unwind_user/sframe: Store sframe section data in per-mm maple tree
Josh Poimboeuf
[PATCH v4 19/39] unwind_user/sframe: Add support for reading .sframe contents
Josh Poimboeuf
[PATCH v4 20/39] unwind_user/sframe: Detect .sframe sections in executables
Josh Poimboeuf
[PATCH v4 21/39] unwind_user/sframe: Add prctl() interface for registering .sframe sections
Josh Poimboeuf
[PATCH v4 23/39] unwind_user/sframe/x86: Enable sframe unwinding on x86
Josh Poimboeuf
[PATCH v4 22/39] unwind_user/sframe: Wire up unwind_user to sframe
Josh Poimboeuf
[PATCH v4 25/39] unwind_user/sframe: Show file name in debug output
Josh Poimboeuf
[PATCH v4 24/39] unwind_user/sframe: Remove .sframe section on detected corruption
Josh Poimboeuf
[PATCH v4 26/39] unwind_user/sframe: Enable debugging in uaccess regions
Josh Poimboeuf
[PATCH v4 27/39] unwind_user/sframe: Add .sframe validation option
Josh Poimboeuf
[PATCH v4 28/39] unwind_user/deferred: Add deferred unwinding interface
Josh Poimboeuf
Re: [PATCH v4 28/39] unwind_user/deferred: Add deferred unwinding interface
Peter Zijlstra
Re: [PATCH v4 28/39] unwind_user/deferred: Add deferred unwinding interface
Peter Zijlstra
[PATCH v4 29/39] unwind_user/deferred: Add unwind cache
Josh Poimboeuf
Re: [PATCH v4 29/39] unwind_user/deferred: Add unwind cache
Peter Zijlstra
[PATCH v4 30/39] unwind_user/deferred: Make unwind deferral requests NMI-safe
Josh Poimboeuf
[PATCH v4 31/39] perf: Remove get_perf_callchain() 'init_nr' argument
Josh Poimboeuf
[PATCH v4 32/39] perf: Remove get_perf_callchain() 'crosstask' argument
Josh Poimboeuf
[PATCH v4 33/39] perf: Simplify get_perf_callchain() user logic
Josh Poimboeuf
[PATCH v4 34/39] perf: Skip user unwind if !current->mm
Josh Poimboeuf
[PATCH v4 35/39] perf: Support deferred user callchains
Josh Poimboeuf
[PATCH v4 38/39] perf script: Display PERF_RECORD_CALLCHAIN_DEFERRED
Josh Poimboeuf
[PATCH v4 36/39] perf tools: Minimal CALLCHAIN_DEFERRED support
Josh Poimboeuf
[PATCH v4 37/39] perf record: Enable defer_callchain for user callchains
Josh Poimboeuf
[PATCH v4 39/39] perf tools: Merge deferred user callchains
Josh Poimboeuf
Re: [PATCH v4 00/39] unwind, perf: sframe user space unwinding
Josh Poimboeuf
[PATCH v2] fgraph: Remove calltime and rettime from generic operations
Steven Rostedt
[PATCH] tracing: Fix output of set_event for some cached module events
Steven Rostedt
[PATCH] tracing: Fix allocation of printing set_event file content
Steven Rostedt
[PATCH v2 00/10] x86/module: rework ROX cache to avoid writable copy
Mike Rapoport
[PATCH v2 01/10] x86/mm/pat: cpa-test: fix length for CPA_ARRAY test
Mike Rapoport
[PATCH v2 02/10] x86/mm/pat: drop duplicate variable in cpa_flush()
Mike Rapoport
[PATCH v2 03/10] x86/mm/pat: restore large ROX pages after fragmentation
Mike Rapoport
[PATCH v2 04/10] execmem: don't remove ROX cache from the direct map
Mike Rapoport
[PATCH v2 05/10] execmem: add API for temporal remapping as RW and restoring ROX afterwards
Mike Rapoport
[PATCH v2 06/10] module: introduce MODULE_STATE_GONE
Mike Rapoport
[PATCH v2 07/10] module: switch to execmem API for remapping as RW and restoring ROX
Mike Rapoport
[PATCH v2 08/10] Revert "x86/module: prepare module loading for ROX allocations of text"
Mike Rapoport
[PATCH v2 09/10] module: drop unused module_writable_address()
Mike Rapoport
[PATCH v2 10/10] x86: re-enable EXECMEM_ROX support
Mike Rapoport
Re: [PATCH v2 00/10] x86/module: rework ROX cache to avoid writable copy
Peter Zijlstra
Re: [PATCH v2 00/10] x86/module: rework ROX cache to avoid writable copy
Peter Zijlstra
[PATCH 0/2] lib/atomic64: ring-buffer: Fix infinite recursion on some 32bit archs
Steven Rostedt
[PATCH 2/2] atomic64: Use arch_spin_locks instead of raw_spin_locks
Steven Rostedt
Re: [PATCH 2/2] atomic64: Use arch_spin_locks instead of raw_spin_locks
Google
[PATCH 1/2] ring-buffer: Do not allow events in NMI with generic atomic64 cmpxchg()
Steven Rostedt
Re: [PATCH 1/2] ring-buffer: Do not allow events in NMI with generic atomic64 cmpxchg()
Google
[no subject]
Steven Rostedt
[no subject]
Steven Rostedt
[PATCH] tracing: Rename update_cache() to update_mod_cache()
Steven Rostedt
[PATCH] tracing: Fix #if CONFIG_MODULES to #ifdef CONFIG_MODULES
Steven Rostedt
Re: [PATCH] tracing: Fix #if CONFIG_MODULES to #ifdef CONFIG_MODULES
Steven Rostedt
[PATCH v2] tools/rtla: Add basic test suite
Tomas Glozar
[PATCH] tracing: Fix -Wundef around 'struct event_mod_load'
Nathan Chancellor
Re: [PATCH] tracing: Fix -Wundef around 'struct event_mod_load'
Steven Rostedt
[PATCH RFC net-next] trace: tcp: Add tracepoint for tcp_cwnd_reduction()
Breno Leitao
Re: [PATCH RFC net-next] trace: tcp: Add tracepoint for tcp_cwnd_reduction()
Jason Xing
Re: [PATCH RFC net-next] trace: tcp: Add tracepoint for tcp_cwnd_reduction()
Breno Leitao
Re: [PATCH RFC net-next] trace: tcp: Add tracepoint for tcp_cwnd_reduction()
Jason Xing
Re: [PATCH RFC net-next] trace: tcp: Add tracepoint for tcp_cwnd_reduction()
Breno Leitao
Re: [PATCH RFC net-next] trace: tcp: Add tracepoint for tcp_cwnd_reduction()
Steven Rostedt
Re: [PATCH RFC net-next] trace: tcp: Add tracepoint for tcp_cwnd_reduction()
Breno Leitao
Re: [PATCH RFC net-next] trace: tcp: Add tracepoint for tcp_cwnd_reduction()
Jason Xing
Re: [PATCH RFC net-next] trace: tcp: Add tracepoint for tcp_cwnd_reduction()
Jason Xing
[PATCH] ring-buffer: fix typo in comment about header page pointer
Zhouyi Zhou
[PATCH] arm64: Kconfig: Remove selecting replaced HAVE_FUNCTION_GRAPH_RETVAL
Lukas Bulwahn
[PATCH] cpuidle: psci: Add trace for PSCI domain idle
Keita Morisaki
Re: [PATCH] cpuidle: psci: Add trace for PSCI domain idle
Steven Rostedt
Re: [PATCH] cpuidle: psci: Add trace for PSCI domain idle
Keita Morisaki
[PATCH v2] cpuidle: psci: Add trace for PSCI domain idle
Keita Morisaki
[PATCH v7] tracing: Adopt __free() and guard() for trace_fprobe.c
Masami Hiramatsu (Google)
[PATCH] seccomp: passthrough uretprobe systemcall without filtering
Eyal Birger
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Oleg Nesterov
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Google
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Eyal Birger
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Oleg Nesterov
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Andrii Nakryiko
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Eyal Birger
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Andrii Nakryiko
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Oleg Nesterov
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Dmitry V. Levin
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Eyal Birger
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Kees Cook
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Darrick J. Wong
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Eyal Birger
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Kees Cook
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Eyal Birger
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Jiri Olsa
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Kees Cook
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Jiri Olsa
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Eyal Birger
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Steven Rostedt
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Oleg Nesterov
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Jiri Olsa
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Andrii Nakryiko
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Steven Rostedt
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Eyal Birger
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Steven Rostedt
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Andy Lutomirski
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Oleg Nesterov
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Kees Cook
Re: [PATCH] seccomp: passthrough uretprobe systemcall without filtering
Oleg Nesterov
[PATCH v2] ftrace: Implement :mod: cache filtering on kernel command line
Steven Rostedt
[PATCH v2 0/2] tracing: gfp: Fix regression of printing GFP flags in user space tracing tooling
Steven Rostedt
[PATCH v2 1/2] tracing: gfp: Fix the GFP enum values shown for user space tracing tools
Steven Rostedt
Re: [PATCH v2 0/2] tracing: gfp: Fix regression of printing GFP flags in user space tracing tooling
Steven Rostedt
[PATCH v2 2/2] tracing: gfp: Remove duplication of recording GFP flags
Steven Rostedt
[PATCH rcu 4/5] rcu-tasks: Move RCU Tasks self-tests to core_initcall()
Paul E. McKenney
[PATCH] tracing: gfp: Fix the GFP enum values shown for user space tracing tools
Steven Rostedt
Re: [PATCH] tracing: gfp: Fix the GFP enum values shown for user space tracing tools
Steven Rostedt
Re: [PATCH] tracing: gfp: Fix the GFP enum values shown for user space tracing tools
Linus Torvalds
Re: [PATCH] tracing: gfp: Fix the GFP enum values shown for user space tracing tools
Steven Rostedt
Re: [PATCH] tracing: gfp: Fix the GFP enum values shown for user space tracing tools
Linus Torvalds
Re: [PATCH] tracing: gfp: Fix the GFP enum values shown for user space tracing tools
Steven Rostedt
Re: [PATCH] tracing: gfp: Fix the GFP enum values shown for user space tracing tools
Linus Torvalds
Re: [PATCH] tracing: gfp: Fix the GFP enum values shown for user space tracing tools
Steven Rostedt
Re: [PATCH] tracing: gfp: Fix the GFP enum values shown for user space tracing tools
Steven Rostedt
Re: [PATCH] tracing: gfp: Fix the GFP enum values shown for user space tracing tools
Steven Rostedt
Re: perf kmem --page stat and gpf_flags translation
Steven Rostedt
[PATCH 0/5] rtla/timerlat: Stop on signal properly when overloaded
Tomas Glozar
[PATCH 1/5] rtla: Add trace_instance_stop
Tomas Glozar
[PATCH 3/5] rtla/timerlat_top: Stop timerlat tracer on signal
Tomas Glozar
Re: [PATCH 3/5] rtla/timerlat_top: Stop timerlat tracer on signal
Steven Rostedt
Re: [PATCH 3/5] rtla/timerlat_top: Stop timerlat tracer on signal
Tomas Glozar
Re: [PATCH 3/5] rtla/timerlat_top: Stop timerlat tracer on signal
Steven Rostedt
[PATCH 2/5] rtla/timerlat_hist: Stop timerlat tracer on signal
Tomas Glozar
[PATCH 4/5] rtla/timerlat_hist: Abort event processing on second signal
Tomas Glozar
[PATCH 5/5] rtla/timerlat_top: Abort event processing on second signal
Tomas Glozar
Re: [PATCH 5/5] rtla/timerlat_top: Abort event processing on second signal
Steven Rostedt
Re: [PATCH 5/5] rtla/timerlat_top: Abort event processing on second signal
Gabriele Monaco
Re: [PATCH 0/5] rtla/timerlat: Stop on signal properly when overloaded
Steven Rostedt
Re: [PATCH 0/5] rtla/timerlat: Stop on signal properly when overloaded
Tomas Glozar
Re: [PATCH 0/5] rtla/timerlat: Stop on signal properly when overloaded
Steven Rostedt
Re: [PATCH 0/5] rtla/timerlat: Stop on signal properly when overloaded
Tomas Glozar
[PATCH 0/3] tracing: Add ':mod:' command to set_event to enable events in modules
Steven Rostedt
[PATCH 1/3] tracing: Add :mod: command to enabled module events
Steven Rostedt
[PATCH 2/3] tracing: Cache ":mod:" events for modules not loaded yet
Steven Rostedt
[PATCH 3/3] selftests/ftrace: Add test that tests event :mod: commands
Steven Rostedt
[PATCH 0/3] selftest/tracing: Allow README requirements to be tested for instance tests
Steven Rostedt
[PATCH 1/3] selftests/tracing: Test only toplevel README file not the instances
Steven Rostedt
[PATCH 2/3] selftests/ftrace: Clean up triggers after setting them
Steven Rostedt
[PATCH 3/3] selftests/tracing: Allow some more tests to run in instances
Steven Rostedt
[PATCH] selftests/tracing: Test only toplevel README file not the instances
Steven Rostedt
Re: [PATCH] selftests/tracing: Test only toplevel README file not the instances
Steven Rostedt
[PATCH] swiotlb: Introduce DMA_ATTR_SKIP_DEVICE_SYNC
Florian Fainelli
Re: [PATCH] swiotlb: Introduce DMA_ATTR_SKIP_DEVICE_SYNC
Robin Murphy
Re: [PATCH] swiotlb: Introduce DMA_ATTR_SKIP_DEVICE_SYNC
Florian Fainelli
[PATCH v4] tools/rtla: Add osnoise_trace_is_off()
Costa Shulyupin
Re: [PATCH v4] tools/rtla: Add osnoise_trace_is_off()
Dan Carpenter
Re: [PATCH v4] tools/rtla: Add osnoise_trace_is_off()
Steven Rostedt
Re: [PATCH v4] tools/rtla: Add osnoise_trace_is_off()
Dan Carpenter
[PATCH v3] Add osnoise_trace_is_off()
Costa Shulyupin
Re: [PATCH v3] Add osnoise_trace_is_off()
Dan Carpenter
[PATCH] rv: Reset per-task monitors also for idle tasks
Gabriele Monaco
[PATCH bpf] bpf: trace: send signals asynchronously if !preemptible
Puranjay Mohan
Re: [PATCH bpf] bpf: trace: send signals asynchronously if !preemptible
Yonghong Song
Re: [PATCH bpf] bpf: trace: send signals asynchronously if !preemptible
patchwork-bot+netdevbpf
Re: [PATCH bpf] bpf: trace: send signals asynchronously if !preemptible
Hou Tao
[PATCHv2 00/11] Get rid of PG_reclaim and rename PG_dropbehind
Kirill A. Shutemov
[PATCHv2 02/11] drm/i915/gem: Convert __shmem_writeback() to folios
Kirill A. Shutemov
[PATCHv2 01/11] mm/migrate: Transfer PG_dropbehind to the new folio
Kirill A. Shutemov
[PATCHv2 04/11] mm/zswap: Use PG_dropbehind instead of PG_reclaim
Kirill A. Shutemov
[PATCHv2 10/11] mm/vmscan: Do not demote PG_dropbehind folios
Kirill A. Shutemov
[PATCHv2 07/11] mm/vmscan: Use PG_dropbehind instead of PG_reclaim in shrink_folio_list()
Kirill A. Shutemov
[PATCHv2 06/11] mm/vmscan: Use PG_dropbehind instead of PG_reclaim
Kirill A. Shutemov
[PATCHv2 03/11] drm/i915/gem: Use PG_dropbehind instead of PG_reclaim
Kirill A. Shutemov
[PATCHv2 05/11] mm/truncate: Use folio_set_dropbehind() instead of deactivate_file_folio()
Kirill A. Shutemov
Re: [PATCHv2 05/11] mm/truncate: Use folio_set_dropbehind() instead of deactivate_file_folio()
Yu Zhao
Re: [PATCHv2 05/11] mm/truncate: Use folio_set_dropbehind() instead of deactivate_file_folio()
Matthew Wilcox
Re: [PATCHv2 05/11] mm/truncate: Use folio_set_dropbehind() instead of deactivate_file_folio()
Yu Zhao
Re: [PATCHv2 05/11] mm/truncate: Use folio_set_dropbehind() instead of deactivate_file_folio()k
Kirill A. Shutemov
[PATCHv2 11/11] mm: Rename PG_dropbehind to PG_reclaim
Kirill A. Shutemov
Re: [PATCHv2 11/11] mm: Rename PG_dropbehind to PG_reclaim
Yu Zhao
Re: [PATCHv2 11/11] mm: Rename PG_dropbehind to PG_reclaim
Christoph Hellwig
Re: [PATCHv2 11/11] mm: Rename PG_dropbehind to PG_reclaim
Kirill A. Shutemov
[PATCHv2 08/11] mm/mglru: Check PG_dropbehind instead of PG_reclaim in lru_gen_folio_seq()
Kirill A. Shutemov
[PATCHv2 09/11] mm: Remove PG_reclaim
Kirill A. Shutemov
Earlier messages