linux-trace-kernel
Thread
Date
Earlier messages
Later messages
Messages by Thread
Re: [PATCH v6] tracing/eprobes: Allow use of BTF names to dereference pointers
Google
Re: [PATCH v6] tracing/eprobes: Allow use of BTF names to dereference pointers
Google
Re: [PATCH v6] tracing/eprobes: Allow use of BTF names to dereference pointers
Steven Rostedt
Re: [PATCH v6] tracing/eprobes: Allow use of BTF names to dereference pointers
Google
Re: [PATCH v6] tracing/eprobes: Allow use of BTF names to dereference pointers
Steven Rostedt
Re: [PATCH v6] tracing/eprobes: Allow use of BTF names to dereference pointers
Jiri Olsa
Re: [PATCH v6] tracing/eprobes: Allow use of BTF names to dereference pointers
Steven Rostedt
Re: [PATCH v6] tracing/eprobes: Allow use of BTF names to dereference pointers
Steven Rostedt
Re: [PATCH v6] tracing/eprobes: Allow use of BTF names to dereference pointers
Google
Re: [PATCH v6] tracing/eprobes: Allow use of BTF names to dereference pointers
Steven Rostedt
[PATCH] unwind: Add sframe_(un)register() system calls
Steven Rostedt
Re: [PATCH] unwind: Add sframe_(un)register() system calls
Jens Remus
Re: [PATCH] unwind: Add sframe_(un)register() system calls
Steven Rostedt
Re: [PATCH] unwind: Add sframe_(un)register() system calls
Thomas Weißschuh
Re: [PATCH] unwind: Add sframe_(un)register() system calls
Steven Rostedt
[PATCH] tracing: Replace BUG_ON with lockdep_assert_held in uprobe_buffer functions
Yash Suthar
Re: [PATCH] tracing: Replace BUG_ON with lockdep_assert_held in uprobe_buffer functions
Steven Rostedt
Re: [PATCH] tracing: Replace BUG_ON with lockdep_assert_held in uprobe_buffer functions
Google
Re: [RFC PATCH 0/3] trace: stack trace deduplication for ftrace ring buffer
Steven Rostedt
[PATCH v16 00/20] unwind_deferred: Implement sframe handling
Jens Remus
[PATCH v16 15/20] unwind_user: Flexible CFA recovery rules
Jens Remus
[PATCH v16 08/20] unwind_user: Stop when reaching an outermost frame
Jens Remus
[PATCH v16 19/20] unwind_user/sframe/x86: Enable sframe unwinding on x86
Jens Remus
[PATCH v16 03/20] unwind_user/sframe: Store .sframe section data in per-mm maple tree
Jens Remus
Re: [PATCH v16 03/20] unwind_user/sframe: Store .sframe section data in per-mm maple tree
Steven Rostedt
[PATCH v16 09/20] unwind_user/sframe: Add support for outermost frame indication
Jens Remus
[PATCH v16 05/20] unwind_user/sframe: Add support for reading .sframe contents
Jens Remus
[PATCH v16 04/20] x86/uaccess: Add unsafe_copy_from_user() implementation
Jens Remus
[PATCH v16 14/20] unwind_user: Flexible FP/RA recovery rules
Jens Remus
[PATCH v16 20/20] unwind_user/sframe: Add prctl() interface for registering .sframe sections
Jens Remus
[PATCH v16 13/20] unwind_user: Enable archs that pass RA in a register
Jens Remus
[PATCH v16 16/20] unwind_user/sframe: Add support for SFrame V3 flexible FDEs
Jens Remus
[PATCH v16 01/20] unwind_user: Add generic and arch-specific headers to MAINTAINERS
Jens Remus
[PATCH v16 07/20] unwind_user/sframe: Wire up unwind_user to sframe
Jens Remus
[PATCH v16 06/20] unwind_user/sframe: Detect .sframe sections in executables
Jens Remus
[PATCH v16 02/20] unwind_user/sframe: Add support for reading .sframe headers
Jens Remus
Re: [PATCH v16 02/20] unwind_user/sframe: Add support for reading .sframe headers
Steven Rostedt
[PATCH v16 10/20] unwind_user/sframe: Remove .sframe section on detected corruption
Jens Remus
[PATCH v16 12/20] unwind_user/sframe: Add .sframe validation option
Jens Remus
[PATCH v16 11/20] unwind_user/sframe: Show file name in debug output
Jens Remus
[PATCH v16 18/20] unwind_user/sframe: Duplicate registered .sframe section data on clone/fork
Jens Remus
[PATCH v16 17/20] unwind_user/sframe: Separate reading of FRE from reading of FRE data words
Jens Remus
[PATCH v2 0/6] rtla: Migrate to libsubcmd for command line option parsing
Tomas Glozar
[PATCH v2 1/6] rtla: Add libsubcmd dependency
Tomas Glozar
[PATCH v2 2/6] tools subcmd: support optarg as separate argument
Tomas Glozar
[PATCH v2 3/6] tools subcmd: allow parsing distinct --opt and --no-opt
Tomas Glozar
[PATCH v2 4/6] rtla: Parse cmdline using libsubcmd
Tomas Glozar
[PATCH v2 6/6] rtla/tests: Add unit tests for CLI option callbacks
Tomas Glozar
[PATCH v2 5/6] rtla/tests: Add unit tests for _parse_args() functions
Tomas Glozar
Re: [PATCH v2 0/6] rtla: Migrate to libsubcmd for command line option parsing
Wander Lairson Costa
[PATCH 0/3] Fix out-of-tree build of some tools
Ben Hutchings
[PATCH 1/3] rtla: Fix output files in source tree
Ben Hutchings
Re: [PATCH 1/3] rtla: Fix output files in source tree
Steven Rostedt
[PATCH 3/3] perf tools: Put Python bytecode in output directory
Ben Hutchings
[PATCH 2/3] perf tools: Put Python egg info in output directory
Ben Hutchings
Re: [PATCH 0/3] Fix out-of-tree build of some tools
Ian Rogers
[RFC PATCH 0/2] random: tracing: Expose last boot ID on persistent instance
Masami Hiramatsu (Google)
[RFC PATCH 1/2] random: Expose boot ID to other subsystems
Masami Hiramatsu (Google)
Re: [RFC PATCH 1/2] random: Expose boot ID to other subsystems
Jason A. Donenfeld
Re: [RFC PATCH 1/2] random: Expose boot ID to other subsystems
Google
[RFC PATCH 2/2] tracing: Record and show boot ID in last_boot_info
Masami Hiramatsu (Google)
Re: [RFC PATCH 2/2] tracing: Record and show boot ID in last_boot_info
Steven Rostedt
Re: [RFC PATCH 2/2] tracing: Record and show boot ID in last_boot_info
Google
Re: [RFC PATCH 2/2] tracing: Record and show boot ID in last_boot_info
Steven Rostedt
Re: [RFC PATCH 2/2] tracing: Record and show boot ID in last_boot_info
Google
Re: [RFC PATCH 0/2] random: tracing: Expose last boot ID on persistent instance
Mathieu Desnoyers
[PATCH] tracing: Move trace_iterator_increment() into trace_find_next_entry_inc()
Steven Rostedt
[PATCH v6] stm: class: Add MIPI OST protocol support
Yingchao Deng
[PATCH v6] stm: class: Add MIPI OST protocol support
Yingchao Deng
[PATCHv3 00/12] uprobes/x86: Fix red zone issue for optimized uprobes
Jiri Olsa
[PATCHv3 05/12] libbpf: Change has_nop_combo to work on top of nop10
Jiri Olsa
Re: [PATCHv3 05/12] libbpf: Change has_nop_combo to work on top of nop10
Andrii Nakryiko
Re: [PATCHv3 05/12] libbpf: Change has_nop_combo to work on top of nop10
Jiri Olsa
Re: [PATCHv3 05/12] libbpf: Change has_nop_combo to work on top of nop10
Jiri Olsa
[PATCHv3 03/12] uprobes/x86: Allow to copy uprobe trampolines on fork
Jiri Olsa
Re: [PATCHv3 03/12] uprobes/x86: Allow to copy uprobe trampolines on fork
Andrii Nakryiko
Re: [PATCHv3 03/12] uprobes/x86: Allow to copy uprobe trampolines on fork
Jiri Olsa
[PATCHv3 11/12] selftests/bpf: Add tests for uprobe nop10 red zone clobbering
Jiri Olsa
Re: [PATCHv3 11/12] selftests/bpf: Add tests for uprobe nop10 red zone clobbering
bot+bpf-ci
Re: [PATCHv3 11/12] selftests/bpf: Add tests for uprobe nop10 red zone clobbering
Jiri Olsa
[PATCHv3 10/12] selftests/bpf: Add reattach tests for uprobe syscall
Jiri Olsa
[PATCHv3 01/12] uprobes/x86: Use proper mm_struct in __in_uprobe_trampoline
Jiri Olsa
Re: [PATCHv3 01/12] uprobes/x86: Use proper mm_struct in __in_uprobe_trampoline
Andrii Nakryiko
[PATCHv3 04/12] uprobes/x86: Move optimized uprobe from nop5 to nop10
Jiri Olsa
Re: [PATCHv3 04/12] uprobes/x86: Move optimized uprobe from nop5 to nop10
Peter Zijlstra
Re: [PATCHv3 04/12] uprobes/x86: Move optimized uprobe from nop5 to nop10
Jiri Olsa
Re: [PATCHv3 04/12] uprobes/x86: Move optimized uprobe from nop5 to nop10
Andrii Nakryiko
Re: [PATCHv3 04/12] uprobes/x86: Move optimized uprobe from nop5 to nop10
Jiri Olsa
Re: [PATCHv3 04/12] uprobes/x86: Move optimized uprobe from nop5 to nop10
Peter Zijlstra
Re: [PATCHv3 04/12] uprobes/x86: Move optimized uprobe from nop5 to nop10
Jiri Olsa
[PATCHv3 08/12] selftests/bpf: Change uprobe syscall tests to use nop10
Jiri Olsa
Re: [PATCHv3 08/12] selftests/bpf: Change uprobe syscall tests to use nop10
bot+bpf-ci
Re: [PATCHv3 08/12] selftests/bpf: Change uprobe syscall tests to use nop10
Andrii Nakryiko
Re: [PATCHv3 08/12] selftests/bpf: Change uprobe syscall tests to use nop10
Jiri Olsa
[PATCHv3 06/12] libbpf: Detect uprobe syscall with new error
Jiri Olsa
Re: [PATCHv3 06/12] libbpf: Detect uprobe syscall with new error
bot+bpf-ci
[PATCHv3 12/12] selftests/bpf: Add tests for forked/cloned optimized uprobes
Jiri Olsa
[PATCHv3 02/12] uprobes/x86: Remove struct uprobe_trampoline object
Jiri Olsa
Re: [PATCHv3 02/12] uprobes/x86: Remove struct uprobe_trampoline object
bot+bpf-ci
Re: [PATCHv3 02/12] uprobes/x86: Remove struct uprobe_trampoline object
Jiri Olsa
Re: [PATCHv3 02/12] uprobes/x86: Remove struct uprobe_trampoline object
Andrii Nakryiko
[PATCHv3 07/12] selftests/bpf: Emit nop,nop10 instructions combo for x86_64 arch
Jiri Olsa
Re: [PATCHv3 07/12] selftests/bpf: Emit nop,nop10 instructions combo for x86_64 arch
bot+bpf-ci
Re: [PATCHv3 07/12] selftests/bpf: Emit nop,nop10 instructions combo for x86_64 arch
Jakub Sitnicki
[PATCHv3 09/12] selftests/bpf: Change uprobe/usdt trigger bench code to use nop10
Jiri Olsa
Re: [PATCH] tracing: Fix unload_page for simple_ring_buffer init rollback
Steven Rostedt
Re: [PATCH] tracing: Fix unload_page for simple_ring_buffer init rollback
Vincent Donnefort
Re: [PATCH v6 23/43] KVM: selftests: Create gmem fd before "regular" fd when adding memslot
Fuad Tabba
Re: [PATCH v6 24/43] KVM: selftests: Rename guest_memfd{,_offset} to gmem_{fd,offset}
Fuad Tabba
Re: [PATCH v6 21/43] KVM: SEV: Make 'uaddr' parameter optional for KVM_SEV_SNP_LAUNCH_UPDATE
Fuad Tabba
Re: [PATCH v6 21/43] KVM: SEV: Make 'uaddr' parameter optional for KVM_SEV_SNP_LAUNCH_UPDATE
Sean Christopherson
Re: [PATCH v6 21/43] KVM: SEV: Make 'uaddr' parameter optional for KVM_SEV_SNP_LAUNCH_UPDATE
Ackerley Tng
Re: [PATCH v6 21/43] KVM: SEV: Make 'uaddr' parameter optional for KVM_SEV_SNP_LAUNCH_UPDATE
Sean Christopherson
Re: [PATCH v6 19/43] KVM: Let userspace disable per-VM mem attributes, enable per-gmem attributes
Fuad Tabba
Re: [PATCH v6 19/43] KVM: Let userspace disable per-VM mem attributes, enable per-gmem attributes
Sean Christopherson
Re: [PATCH v6 18/43] KVM: Move KVM_VM_MEMORY_ATTRIBUTES config definition to x86
Fuad Tabba
Re: [PATCH v6 17/43] KVM: guest_memfd: Determine invalidation filter from memory attributes
Fuad Tabba
Re: [PATCH v6 16/43] KVM: guest_memfd: Use actual size for invalidation in kvm_gmem_release()
Fuad Tabba
Re: [PATCH v6 16/43] KVM: guest_memfd: Use actual size for invalidation in kvm_gmem_release()
Sean Christopherson
Re: [PATCH v6 16/43] KVM: guest_memfd: Use actual size for invalidation in kvm_gmem_release()
Fuad Tabba
Re: [PATCH v6 16/43] KVM: guest_memfd: Use actual size for invalidation in kvm_gmem_release()
Ackerley Tng
Re: [PATCH v6 15/43] KVM: guest_memfd: Handle lru_add fbatch refcounts during conversion safety check
Fuad Tabba
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Balbir Singh
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Balbir Singh
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Balbir Singh
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Balbir Singh
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Balbir Singh
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Balbir Singh
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
David Hildenbrand (Arm)
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
David Hildenbrand (Arm)
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Zenghui Yu
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [Lsf-pc] [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Vlastimil Babka (SUSE)
Re: [Lsf-pc] [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
David Hildenbrand (Arm)
Re: [Lsf-pc] [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Vlastimil Babka (SUSE)
Re: [Lsf-pc] [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
David Hildenbrand (Arm)
Re: [Lsf-pc] [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [Lsf-pc] [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Vlastimil Babka (SUSE)
Re: [Lsf-pc] [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [Lsf-pc] [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Vlastimil Babka (SUSE)
Re: [Lsf-pc] [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [Lsf-pc] [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Brendan Jackman
Re: [Lsf-pc] [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [Lsf-pc] [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
David Hildenbrand (Arm)
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Balbir Singh
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Balbir Singh
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Arun George/Arun George
Re: [LSF/MM/BPF TOPIC][RFC PATCH v4 00/27] Private Memory Nodes (w/ Compressed RAM)
Gregory Price
[PATCH v4 1/2] tracing: Return ERR_PTR() from expr_str()
Pengpeng Hou
[PATCH v4 2/2] tracing: Bound histogram expression strings with seq_buf
Pengpeng Hou
Re: [PATCH v4 2/2] tracing: Bound histogram expression strings with seq_buf
Steven Rostedt
Re: [PATCH v4 1/2] tracing: Return ERR_PTR() from expr_str()
Steven Rostedt
[PATCH v2] ring-buffer: Fix reporting of missed events in iterator
Steven Rostedt
Re: [PATCH v2] ring-buffer: Fix reporting of missed events in iterator
Google
[PATCH] tracing: Fix README path for synthetic_events
ao . sun
[PATCH] trace: allocate fields with elt struct
Rosen Penev
Re: [PATCH] trace: allocate fields with elt struct
Google
[PATCH] tracing: Do not call map->ops->elt_free() if elt_alloc() is not succeeded
Masami Hiramatsu (Google)
Re: [PATCH] tracing: Do not call map->ops->elt_free() if elt_alloc() is not succeeded
Tom Zanussi
[PATCH] tracing: Use flexible array for entry fetch code
Rosen Penev
Re: [PATCH] tracing: Use flexible array for entry fetch code
Google
Re: [PATCH v2] tracepoint: add lockdep rcu_is_watching() check to trace_##name##_enabled()
Steven Rostedt
Re: [PATCH] tracing: simplify pages allocation
Steven Rostedt
[PATCH] ftrace: Use flexible array for hash buckets
Rosen Penev
Re: [PATCH] ftrace: Use flexible array for hash buckets
Steven Rostedt
Re: [PATCH] ftrace: Use flexible array for hash buckets
Rosen Penev
Re: [PATCH] ftrace: Use flexible array for hash buckets
kernel test robot
Re: [PATCH v2] tracing/osnoise: Array printk init and cleanup
Steven Rostedt
Re: [PATCH v2] tracing/osnoise: Array printk init and cleanup
Crystal Wood
Re: [PATCH v2] tracing/osnoise: Array printk init and cleanup
Crystal Wood
Re: [PATCH v2] tracing/osnoise: Array printk init and cleanup
Steven Rostedt
Re: [PATCH v6 20/43] KVM: guest_memfd: Enable INIT_SHARED on guest_memfd for x86 Coco VMs
Ackerley Tng
Re: [PATCH v6 20/43] KVM: guest_memfd: Enable INIT_SHARED on guest_memfd for x86 Coco VMs
Fuad Tabba
[PATCHv2] tracing: simplify pages allocation
Rosen Penev
Re: [PATCHv2] tracing: simplify pages allocation
Google
[PATCH] ring-buffer: Fix reporting of missed events in iterator
Steven Rostedt
Re: [PATCH] ring-buffer: Fix reporting of missed events in iterator
Google
Re: [PATCH] ring-buffer: Fix reporting of missed events in iterator
Steven Rostedt
[no subject]
Steven Rostedt
Re: [PATCH v2] perf/ftrace: Fix WARNING in __unregister_ftrace_function
Steven Rostedt
Re: [PATCH v2] perf/ftrace: Fix WARNING in __unregister_ftrace_function
Rik van Riel
Re: [PATCH v2] perf/ftrace: Fix WARNING in __unregister_ftrace_function
Google
Re: [PATCH v2] perf/ftrace: Fix WARNING in __unregister_ftrace_function
Steven Rostedt
Re: [PATCH v2] perf/ftrace: Fix WARNING in __unregister_ftrace_function
Steven Rostedt
[PATCH v20 00/10] ring-buffer: Making persistent ring buffers robust
Steven Rostedt
[PATCH v20 03/10] ring-buffer: Add persistent ring buffer invalid-page inject test
Steven Rostedt
[PATCH v20 08/10] ring-buffer: Have dropped subbuffers be persistent across reboots
Steven Rostedt
Re: [PATCH v20 08/10] ring-buffer: Have dropped subbuffers be persistent across reboots
Google
[PATCH v20 05/10] ring-buffer: Cleanup persistent ring buffer validation
Steven Rostedt
[PATCH v20 09/10] ring-buffer: Show persistent buffer dropped events in trace file
Steven Rostedt
Earlier messages
Later messages