I have an Atlantis Land S1001 UPS device.
It seems that is an oem product of abler excelsior from taiwan.

Under windows it is working as USB-HID device with the standard windows driver.
The software the gave me on CD is UPSILON 2000 for windows and linux.
I bought it because they have linux software on cd, but then i saw that this software is useless because doesn't work with the usb interface on the device. an on this version they removed the rs232 interface.

when i attach it at my pc, it is recognized as
T:  Bus=03 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  8 Spd=1.5 MxCh= 0
d:  Ver= 1.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8  #Cfs=  1
P:  Vendor=0001 ProdID=0000 Rev= 1.00
S:  Manufacturer=UIS_ABLER
S:  Product=USB to SERIAL
C:* #Ifs = 1 Cfg#= 1 Atr=80 MxPwr=100mA
I:  If#= 0 Alt= 0 #EPs= 0 Cls=03(HID ) Sub=00 Prot=00 Driver=(none)

now i tried to load the usbhid module and i get the following error:

usb 3-2: new low speed USB device using uhci_hcd and address 7
usb 3-2: Product: USB to SERIAL
usb 3-2: Manufacturer: UIS_ABLER
drivers/usb/input/hid-core.c: couldn't find an input interrupt endpoint
usbhid: probe of 3-2:1.0 failed with error -5

it seems an usb-problem or am i wrong?

I looked arround on google, but i didn't find anyone using this device on linux, or having the same error.
I hope someone on this list could help me, getting it to work.

excuse my english,

SF.Net email is Sponsored by the Better Software Conference & EXPO
September 19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
To unsubscribe, use the last form field at:

Reply via email to