> I reread this patch and tried to see it more in the context of the other
> and the existing code. The naming of the existing string tables doesn't help
> getting this right, however I have a proposal:
> typec_find_port_power_role() to get to TYPEC_PORT_SRC/SNK/DRP
> typec_find_port_data_role() to get to TYPEC_PORT_DFP/UFP/DRD
> typec_find_power_role() to get to TYPEC_SINK/SOURCE
> and sometime, if the use should arise
> typec_find_data_role() to get to TYPEC_DEVICE/HOST
> I think it is fairly comprehensible, *_port_* concerns a capability and
> *_port_* it is an actual state. Plus it matches the names of the constants.
Reasonable to me, I was using "type" to concern a capability but it was not
preferred, if Heikki agree this proposal, I will change the API names like this
and include 4 APIs above.