My name is Alfredo from Spain, I'm a secondary school teacher and I
worked with my students  with the lego usb tower, I write you in
reference to the following commit

patch: 9363741

I have a little problem with the legousbtower module of kernel. I was
working with kernel 4.4 and I had no problem with this module, each
time that I connected the tower I have the following message in my

[ 4927.822527] usb 3-1: new low-speed USB device number 2 using xhci_hcd
[ 4928.022168] usb 3-1: New USB device found, idVendor=0694, idProduct=0001
[ 4928.022185] usb 3-1: New USB device strings: Mfr=4, Product=26,
[ 4928.022188] usb 3-1: Product: LEGO USB Tower
[ 4928.022190] usb 3-1: Manufacturer: LEGO Group
[ 4929.914818] legousbtower 3-1:1.0: LEGO USB Tower firmware version
is 1.0 build 134
[ 4929.915157] legousbtower 3-1:1.0: LEGO USB Tower #-160 now attached
to major 180 minor 0
[ 4929.915517] usbcore: registered new interface driver legousbtower

And I can use nqc without any problems.

Since kernel 4.9 (I've tested it with kernel 4.9 and 4.10), I'm having
the same issue. Each time that I connect the legousbtower I have this

[   51.036609] usb 1-2: USB disconnect, device number 5
[   53.025125] usb 1-2: new low-speed USB device number 6 using xhci_hcd
[   53.173087] legousbtower 1-2:1.0: LEGO USB Tower get version
control request failed
[   53.173102] legousbtower: probe of 1-2:1.0 failed with error -11

I have tested it in two different distros and in different computers
(Lliurex that is based in Ubuntu and Manjaro that is based in Arch). I
have also tried to download kernel 4.4 directly to see if it is a
problem of the distro, and it works perfectly with the kernel.
I have also tried to compile the module from kernel 4.4 in 4.9 but I'm
having the same problem, probably at this time I'm groping because
this is beyond my knowledge.
I have never report a bug to the kernel and I don't really know if it
could be a bug, before report it, I would like, if it isn't an
inconvenience for you, if it is really a bug related with the last
update of the legousbtower module or what it is, because I'm lost.
If you need that I do some test I'm available.
I know that lego RCX is quite old but I and plenty of my colleagues in
Valencia use it and before update the kernel, this issue can be a
handicap for them.

Thank you for your attention.
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to