On Tue, Dec 05, 2017 at 05:20:56PM +0800, Joe Lee wrote:
> Dear Greg:
> I am sorry if this has caused you any inconvenience.
> I can't understand what is a good line-wrapping.
> Can you check the line-wrapping for me?
> 
> > For AMD Promontory xHCI host,
> > although you can disable USB 2.0 ports in BIOSsettings,
> > those ports will be enabled anyway after you remove a device on
> > that port and re-plug it in again. It's a known limitation of the chip.
> > As a workaround we can clear the PORT_WAKE_BITS.

Ick, don't you have a valid editor to wrap lines correctly?

It should be wrapped at 72 columns, like your editor should show when
you make the git commit.  Most editors can easily reformat for the
correct line-length.  I know vim and emacs can do that.

For this, it should look like:

-------
For AMD Promontory xHCI host, although you can disable USB 2.0 ports in
BIOSsettings, those ports will be enabled anyway after you remove a
device on that port and re-plug it in again. It's a known limitation of
the chip.  As a workaround we can clear the PORT_WAKE_BITS.
-------

Much easier to read, don't you agree?

> 
> >This all goes below the next --- line.
> >This ends up being dropped because you put --- above.
> 
> Is it the same as below?
> 
> ---
> Signed-off-by: Joe Lee <asmt.sw...@gmail.com>

No, the signed-off-by needs to go above the line.

Look at the many patches sent to this list, or any other kernel mailing
list, they are all in the correct format, and should be easy to copy.

> v9: Fix multi-line comment style
> v8: usb_amd_pt_check_port() function return a bool
> v7: add a empty function for the case
> when CONFIG_USB_PCI is not defined in pci-quirks.h
> v6: Fix coding format.
> v5: Add check disable port setting before set PORT_WAKE_BITS
> v4: Remove the patch code in case USB_PORT_FEAT_REMOTE_WAKE_MASK
> v3: Fix some checkpatch.pl
> ---
> 
> >And shouldn't you be using a company email address?
> Our company email can not be sent by Git.
> Is there any problem with Gmail?

You can send using gmail, but sign off with your correct corporate email
address if at all possible please.

You can also use the "From:" line in your changelog comment (as the
first line) to properly set the author to be from that corporate account
as well.  See the kernel documentation for how to do this (it's in the
submitting patches file.)

hope this helps,

greg k-h
--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to