This patch series adds several improvements to the readability, the
output format of rc_stats and the calculated statistics of Minstrel
and Minstrel-HT. Variable names got more consistent and functions
got unified between both rate control algorithms.

Greetings Thomas



[PATCH 01/10] mac80211: enhance readability of Minstrels rc_stats
[PATCH 02/10] mac80211: enhance readability of Minstrel-HTs rc_stats
[PATCH 03/10] mac80211: add new Minstrel statistic output via csv
[PATCH 04/10] mac80211: add new Minstrel-HT statistic output via csv
[PATCH 05/10] mac80211: unify Minstrel & Minstrel-HTs calculation of
[PATCH 06/10] mac80211: improve Minstrel variable & function naming
[PATCH 07/10] mac80211: restructure per-rate throughput calculation
[PATCH 08/10] mac80211: add max. lossless throughput per rate to
[PATCH 09/10] mac80211: reduce calculation costs of EWMA
[PATCH 10/10] mac80211: add standard deviation to Minstrels

net/mac80211/rc80211_minstrel.c            | 129 +++++++++++------
net/mac80211/rc80211_minstrel.h            |  50 +++++--
net/mac80211/rc80211_minstrel_debugfs.c    | 130 ++++++++++++++---
net/mac80211/rc80211_minstrel_ht.c         | 216 +++++++++++++++-------------
net/mac80211/rc80211_minstrel_ht.h         |   5 +-
net/mac80211/rc80211_minstrel_ht_debugfs.c | 224 +++++++++++++++++++++++++----
6 files changed, 553 insertions(+), 201 deletions(-)
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to [email protected]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to